Publish a feature service with subtypes in AGOL? How does it work?

04-08-2021 11:09 AM
New Contributor III

I have limited experience with subtypes but have a map in Pro that has 3 features with subtypes and attribute rules. I just have two subtypes, one with a domain and one with freetext values. So the user can select the freetext subtype if the feature collected is not in the domain list, and manually enter the value. That simple and it works fine in Pro. However, when I publish the layers to AGOL:

1. The domain disappears from the point feature only, but is retained in the line and poly layers

2. There is no way to select the subtype for lines/polys and it just has 1 (the default subtype value) in the field. I can type any value into that field with no effect.

3. I tried publishing the map with the layers symbolized by subtype value (coded and freetext) but it totally dropped the domains and if I try to symbolize on the domain field (or both the subtype and domain) it just shows 'other'

I've never tried to do this before and not entirely sure how it's supposed to work. Help please? Thanks, cob

0 Kudos
1 Reply
MVP Esteemed Contributor

Unfortunately, subtypes and attribute rules don't directly translate over to feature services, and remain some of the main selling points of using published enterprise geodatabase services

As you've seen, domains can transfer on a per-field basis, but cannot "interact" with other fields.

The closest thing you can get in AGOL is to define the editing templates as faux-subtypes.

  1. Base layer symbology on the "subtype" field.
  2. Open Manage Templates from the Edit tab in a map. By default, there should be a single feature type in each symbol group.


  3. Add new types to the symbol categories. In this way, you can limit the available templates to those with pre-defined options in some of their fields.

Unfortunately, this isn't the same as try subtype domains, but it's about the closest you'll get on AGOL.

- Josh Carlson
Kendall County GIS
0 Kudos