Opening Map Viewer Corrupting Data?

174
0
03-02-2020 11:55 AM
Chris_Anderson
Occasional Contributor

Hi,

This week, I've run into an issue where I've created a feature service through Survey123 Connect, both from scratch and from an uploaded Geodatabase. Everything runs smooth, I can create the survey, fill-it out, then upload the points. As soon as I open the service in Map Viewer, I get a warning triangle/exclamation point and a text box with "The layer <layer name> did not draw completely". When I go to my survey123 home page (survey123.arcgis.com) and look at the data table, I get a "An error occurred while loading the page. Some features may not work." error. I have built this same survey 5 or 6 times and I get the same error. This last time, I built it completely from scratch, not using an existing Excel spreadsheet. I published it, checked the table in AGO, checked the table in Survey123 home page, and everything worked. I open the feature service in Map Viewer to set up the legend based upon the domain in the feature service, I get the orange triangle. I open the table in Survey123 home page, I get the "An error occurred..." banner at the top. This making the feature service unusable. I have tried clearing out my browser cache. I have tried looking at the data on a different PC. I tried building the survey on a different machine. All give me the same error. To make things even worse, I can see the data in Map Viewer Beta, configure the pop-up, change the legend, save as a new file. But when I try to make a Web Application from the map, the data are not there. I run into the same problem.

Has anyone else run into this?  I can make surveys, web maps, and web apps from feature views without any issues.

Any help you an provide is greatly appreciated.

Chris Anderson

Florida Fish and Wildlife Conservation Commission

0 Kudos
0 Replies