Only see layer 0 in ArcMap when adding data from ArcGIS Online. BUG??

3813
20
08-17-2016 01:58 PM
BrantCarman
Occasional Contributor

I have multiple feature services published to ArcGIS Online that contain more than one layer.  I often add this data to ArcMap straight from ArcGIS Online in order to perform local edits.  I've noticed with some of my services that I only see layer 0 when I add the data to ArcMap, which is a pretty big nuisance, because with these services I can only view and perform edits to layer 0 in ArcMap.  Any other layers just don't show up in the table of contents (i.e. 1,2,3, etc).

As I mentioned, this only occurs with some of my layers.  The only difference that I can see between the services that experience this issue and the ones that don't:  Services that only show layer 0 in ArcMap were published with symbolgy that is attribute based rather than feature only; specifically, layer 0 is symbolized based on attribute data, and all other layers are "feature only" symbology.  

My services that are published with all layers symbolized as "feature only" seem to function correctly when brought into ArcMap.

At this point I'd like to think that I'm onto a bug:

If you publish multiple layers to a FS on AGOL, and the symbology for layer zero is attribute based, it appears that layer 0 is the only layer that makes it down to ArcMap for local viewing/ editing when added from AGOL.

 

Has anybody else experienced this?

Thanks.

-Brant

20 Replies
DanielleKulas
Occasional Contributor III

Yup, thanks, it was definitely logged as a bug! The other workaround we found for users that need to access the data but don't own it and thus can't add via 'my hosted services' is to save the feature service in a web map, then open the webmap in ArcMap.

JoelThompson1
New Contributor II

I just came across this same issue. I did some testing and found that it was only when I changed the configuration on individual layers within the hosted Feature Layer that "Open in ArcGIS Desktop" would only load the first layer.

To test, I published a new Feature Layer that included four layers. Initially opening in Desktop showed all layers and worked fine. I went into the Feature Layer settings page and changed some things on the Overview tab - still fine. On the Settings tab I enabled edit tracking, optimized layer drawing, and allowed export - still opened correctly in Desktop. Then I went into the Visualization tab and configured the popup for one of the layers. After saving the layer, "Open in ArcGIS Desktop" now displays just the first layer in the hosted Feature Layer.

Re-publishing and overwriting the existing Feature Layer doesn't seem to fix the issue. I'm just getting this project set up, so I'm going to modify the layers in my mxd and publish a new Feature Layer.

0 Kudos
deleted-user-yMSQSHvui0e5
New Contributor III

Is there any planned update for this issue? Seems like a fairly significant shortcoming. Essentially our users can't use layers in ArcMap if they were published with more than one feature class (which is most)

MikeSautkulis
New Contributor III

I just came across this bug today. The workaround listed doesn't work since the service doesn't appear in My Hosted Services if the user is not the owner or the service is shared only with a group within an organization. Anybody have a solution to this?

Is the solution really to only publish Feature Services with a single layer in them if the end user is going to be using them in ArcMap?

ArcGIS Desktop 10.6

Version: 10.6.0.8321

0 Kudos
KorinMiles
New Contributor

A workaround that I have used is to create a layerfile off of your feature service and share that with other users. Then they can add the layerfile to their map and it will function normally. Of course, the person who owns the service will have to be the one to create the layerfile.

0 Kudos
KatieCullen
Regular Contributor II

The following bug has been marked as In Product Plan:

BUG-000098263: Adding a hosted feature service in ArcMap using the .. 

If you are experiencing this issue and you would like to receive updates on the status through your My Esri account please contact support and request to be attached.

DanielleKulas
Occasional Contributor III

Thanks for the update. I see the ticket was modified 3 days ago, as well as the one for https://support.esri.com/bugs/nimbus/TklNMTA0NDY3. I've been spending hours this week republishing data with very minimal schema changes so as to avoid this issue for our public facing datasets, would be nice to know if the fix will be nearer term vs. longer term. Is there any kind of timeline for the product plan?

0 Kudos
JeremyL
New Contributor II

I have the same problem with only the first layer of an AGOL Feature Service being added to Arcmap 10.6 using the Add Data button. The workaround noted in the bug that Danielle

mentioned at : https://support.esri.com/bugs/nimbus/TklNMTA0NDY3 where you edit the JSON via the ArcGIS Online Assistant worked for me. The "Data" window mentioned can be hard to find depending on your browser - you may need to scroll down till you see it. It appears to work for users who are not the owner of the FS as well. 

Thanks - it would be great to get this fixed.

DanielleKulas
Occasional Contributor III

Thanks, the ArcGIS Online Assistant workaround is good to know! Always scary to me to edit the JSON but I did it on a test dataset and everything appears as it should.

0 Kudos
lowers_808
New Contributor III

Hi, curious if there is any update to this?

Thanks