Issues with'newer' Map Viewer and Dashboard Apps

1404
7
04-20-2021 01:32 AM
DarrenDe_Lange
New Contributor III

Good morning

I am having issues with the 'newer' Map Viewer and Dashboard apps.
I am able to view maps and layers in the classic versions of Map Viewer and Dashboard.
However, when I try view these maps and layers in Map Viewer and Dashboard, they either do not show or shows a message saying that the map can not be loaded.
When I try open the map viewer, the screen is completely white, blank.

Thank you in advance for any help on this. 

0 Kudos
7 Replies
DavidColey
Frequent Contributor

Hi Darren, no I don't have any help I can give you other than to say others seem to be having a variety of issues as well.  Here is my related post:

https://community.esri.com/t5/arcgis-online-questions/map-viewer-classic-and-map-viewer-layer-alignm...

To which I can also add that I could not load a referenced feature service to the new map viewer.  It came back as 'unsupported'

EllenNodwell_IntegraShare
Occasional Contributor

I am testing maps in AGOL today to see what issues I might have, because I do like the enhanced functionality of the new map viewer version and would like to use it.  Transitioning to new from old always requires some "change management". 

Here are a few tactics that I use to troubleshoot issues:

I found in testing that some issues were machine-type dependent for some apps - that the app worked fine on my main machine but on my notebook PC, it did not come up and display normally.

Related to content not showing, I have found issues with using certain maps and apps in AGOL with certain browsers and not others.

  • When I switch to a different browser, the content displays, where it did not or had issues in another browser "brand". 
    • I imagine with the variety of devices and device-types that exist today, it would be quite difficult to have these work 100% of the time on all devices and within the various browser types across devices. 
  • There are quirks with some web apps (in general, not just ArcGIS web apps) where something retained in your browser history from one website causes issues with other site content. 

    • One thing I try to do when I am having display issues in browsers is to go clear my history, cookies, etc., shut down the browser, open it up, and login again to AGOL to see if that fixes the problem(s). 

Sometimes I use the web browser's developer tools to dig deeper for errors.  (See example below)

  • Every browser flavor has these.  In your browser, usually, you go into your settings, and there will be a menu item for tools or developer tools.
  • If you go into a Console view, you can usually see what is throwing errors when the page is loading, to at least give you some hints as to what is going on. 
  • Here is an example of what I found when I loaded one of my maps created in Classic Map Viewer into the new Map Viewer - I found out exactly what the problem was with one layer's labeling situation when I used the Console view in the Edge DevTools (Edge Browser), and opened up the error to see the details.  It says that the Renderer of type heatmap does not currently support labeling.  Ok, so I know that this is causing one issue.  I have to open up the error message, where it has a right pointing arrow with an f to see what is going on in more detail in the error message.

EllenNodwell_IntegraShare_0-1618926620346.png

I don't know if this will help you troubleshoot - and of course, there are always the great folks at Esri Support who can help you dig deeper.

I will try to follow up on this in this feed if I discover anything else related to this.  Hope it helps.

DarrenDe_Lange
New Contributor III

Thank you Ellen - your message is much appreciated. I will be taking note of these factors as I troubleshoot. 

ChrisWhitmore
Esri Regular Contributor

Hi Darren, would it be possible to share the map where you're seeing this (if only permissible to share privately, you can invite my username - cwwhitmore to a private group and share that way). Also..do you still see the issue this morning? It may already be resolved.

Thanks,

Chris

0 Kudos
DarrenDe_Lange
New Contributor III

Tested the map viewer is Microsoft edge and it works, the map viewer will not open in Google Chrome.

Really strange.  

0 Kudos
PaulLong
New Contributor II

Ellen,

I have an issue with editing in the NEW non-Beta? map viewer. We want that new functionality also (like the application of Attribut rules that is visible to the field workers)We have customized maps for our FIELD MAPS mobile crews and I configure these to try and streamline our field workflow. I'm noticing in both Chrome & Edge on w10 that the map will not show me the immediately revised geometry on an edit on a line feature unless I refresh the entire browser. This is a pain as we have several level of authentication on editing our production DB directly in real-time and it causes a re-polling of the feature service which requires a login again. This is not the same on the actual IOS device in the field as it stores that login and continues to refresh the recent change.

Video clip

https://www.screencast.com/t/YJ8hBXTp03d

0 Kudos
Bob_Spaulding
New Contributor III

Darren, all,

I think I may have a solution that would be helpful in many cases. 

Your symptoms sound the same as ones we've had on a couple of occasions to two different users in our organization.  Based on your description, I'm guessing you use Chrome for your work in AGO.  Try deleting your Chrome cache (and any other items in the delete list about "Application Cache", or "data storage" or the like), and then restart your browser.  That did the trick for us.  For the same reason, that's why Edge worked for you while Chrome did not.

Now, that begs the question: do other users of the problem dashboards have the same issue?  I don't know.  For us, we're working on an as-of-yet unlaunched set of dashboards, so most others will never have visited before and presumably wouldn't have the offending data in their cache, so it does not seem terribly worrying.  But it is frustrating.

0 Kudos