I can't work out why I'm getting an error trying to update a data layer in ArcGIS on-line

08-24-2018 08:57 AM
Occasional Contributor II

I have a hosted layer in ArcGIS on-line that I'm using in a map



I'm trying to update this layer having created some additional examples in ArcMap. As far as I can tell the data I'm adding is in an identical format; the field names match; the types are the same. But when I attempt to append I get an error saying - There was an error appending the uploaded data to the layer . There's no further information showing what's wrong and I'm stumped.

Any suggestions would be most welcome.

Tags (2)
0 Kudos
4 Replies
Occasional Contributor III

I think the name of the updated file has to match the original one....is that the problem?

New Contributor III

I tried this solution on what sounds like a similar problem and it worked. The feature I needed to update was "Water Hydrant." My original input was something like "03 Water Hydrants_TableToExcel..." which I tried to append as a spreadsheet as well as a .csv. When I renamed to the .csv file to "Water Hydrants.csv" the operation completed successfully.

0 Kudos
by Anonymous User
Not applicable

I would suggest contacting Support to get a case created. If you are outside the United States please contact your distributor.

0 Kudos
New Contributor III

I was having an error recently too and after a serious "cleaning" and "simplifying" of my excel spreadsheet I got the data to upload okay.  I made sure all my field headings matched the AGOL feature class I was uploading to...making sure no spaces or underscores or special characters remained. I also made sure every record had a good latitude and longitude coordinate in the same projection as my feature class and made sure there were no extra rows at the bottom of the sheet.  I didn't test after each step of my cleaning but I managed to make a spreadsheet that was full of issues that I fixed and got it to append successfully. 

0 Kudos