How do you remove thousand comma separators on ArcGIS web map labels and tables?

01-10-2020 08:51 AM
New Contributor II

How do you remove thousand comma separators in labels on ArcGIS Online web maps? I know you can remove them in the pop-ups, but how do you remove them in the labels and tables? How would you be able to do this without having to write an arcade expression?

7 Replies
MVP Esteemed Contributor

When you configure a field in the popup to change the "Use 1000 Separator" option, that change is reflected in the table immediately. For the labels, if you've already created them and then changed the separator option, you have to click on "Manage labels" and then click OK to resync them.

New Contributor II

I think that about does it thank you!

0 Kudos
Esri Esteemed Contributor

Hi Jan Vincent Punzalan ,

Could you mark the post by kenbuja as the correct answer?

0 Kudos
Occasional Contributor II

Why would one have to do that for the labels to resync?  Shouldn't that automatically happen after the "Use 1000 Separator" has been unchecked, saved, and the map refreshed?  So, one has to actually take one more step and go to "Manage Labels" for the labels to actually refresh and label correctly.  Seems totally illogical and could be taken care of in ESRI's code fairly easily.  Seems like a bug to me....

New Contributor II

This workflow did not work for my data

New Contributor

Agreed. This did not work for me either.

New Contributor

^Work flow also did not work.


In Excel, I format the data to text -- cells have no comma written in, so cell is as is with no comma. There is no comma separator check box in Esri Online for me to uncheck, yet commas appear in data when viewed in pop up. There are no commas present in attribute table.

Have been dealing with this issue for a while and is having major impacts on individuals attempting to use the map