Help - Cannot Edit Feature Layer in ArcGIS Online

765
3
01-28-2022 05:01 AM
MHeneghan
New Contributor

Good Morning

I am looking for assistance in solving an issue I have had on ArcGIS Online for quite some time.

I have spent time on the phone and communicating via email with ESRI support with no luck. Myself and all other organization personnel have the right roles/user types, and all editing capabilities have been enabled in the feature layers settings as well as the specific fields I wanted to edit (configure pop up settings). We have checked these settings repeatedly. When I try to edit directly through the Data tab of the feature layer or through the editing widget on a Web Map Application I basically just get a loading bar that never ends.

I've tried reuploading the hosted feature layer and redoing the maps as well.

This layer was uploaded via "+ New Item" button in the My Content tab and uploading a zipped Geodatabase with three feature classes. I have tried a zipped geodatabase with only one feature class as well.

While messing around yesterday I decided to upload a new hosted feature layer that was a zipped shapefile of one of the feature classes from the Geodatabase. Editing works just fine on this feature layer (from a Shapefile), but it will not work with the geodatabase layer.

I would just use the feature layer uploaded from the shapefile, but the layer includes hyperlinks that were created in the attribute table for the geodatabase classes in ArcPro. As far as I can tell, these hyperlinks will not work coming from a shapefile.

Anyone have any advice here or known workarounds? This has been a major pain in my side for quite awhile and really the only thing keeping me from finishing a nice working dashboard for my organization.

  • We need to have functioning hyperlinks
  • Our employees need the ability to edit attributes

Below are some screen shots.

 

 

MHeneghan_0-1643374812089.png

Editing options all enabled under Settings tab

MHeneghan_1-1643374812093.png

Screen when I try to edit in the feature layer data tab. The loading circle will continue for a minute or two and then go away and the edit will disappear.

MHeneghan_2-1643374812119.png

Pop up when I try to edit attributes in Map Viewer Classic Attribute Table

 

 

0 Kudos
3 Replies
JavierCMartínezPrieto
Occasional Contributor

hello
I don't know if it will help you, but try to create a view of the layer and operate from it.

Regards

Javier C. Martinez Prieto
0 Kudos
MHeneghan
New Contributor

Could you elaborate here?

0 Kudos
AdrianWelsh
MVP Honored Contributor

Can you publish the layer from ArcGIS Pro or ArcMap (instead of just uploading via zipped file)? Also, why can you not use hyperlinks from a shapefile? What happens when you try?