ArcGIS Online attachments not displaying?

08-06-2018 01:15 PM
New Contributor III

I'm having problems with some attachments in an ArcGIS online story map. The layer is a map service that is being fed from a replicated file geodatabase off of a local ArcGIS Server. All of my attachments are simply links inside the pop up, and most of the photos show up fine when clicked. However, some of the photos when clicked give me a black screen with a small white box in the center, like it can't find the photo.

I'm able to access these photos fine within a desktop application like ArcMap, but for some reason a few of the photos will not show up inside the web app. I tested both the original database and the replicated geodatabase and I can access the photos locally from both gdb's, so I don't think it's a replication problem. 

Has anyone else encountered this problem? Is it an AGOL problem or a Server problem? 


EDIT 8/17/18: I tried removing the attachments that weren't working, changing their file format from jpg to png, and then adding them again and this appeared to fix the problem.

1 Reply
New Contributor II

I just wanted to say thank you for posting what you did to resolve your problem.  I was having a similar issue and changing the jpg to png solved the problem.  I was loosing my mind!  

0 Kudos