Fields Map Viewer Broken?!? New Update?!?

1345
12
03-23-2022 04:46 AM
neomapper
Occasional Contributor

So I guess an update happened to Field Maps (Map Viewer) which is now completely broke. This is so frustrating...

Issues:

1) Editor doesn't allow you to add points to the map

2) When you zoom in so far you cannot select items to see information

3) Map randomly stops allowing you to scroll or zoom

4) When you click the sketch tool a bunch of other property tools will disappear

5) If you have the same layer in the map more than once the outline stroke thickness will randomly get bigger

6) Certain conditions for the Form creator tool isn't working. 

---------------------------------------

Dashboard Issues with the latest update...

1) Embedded Survey123 is not working 

neomapper_0-1648036977433.png

 

Embedded survey123 URL not longer work

 

I'm a little surprised this update made it Live seeing all the issues right now

12 Replies
DembaEstadual
New Contributor II

Hello @neomapper,

I encountered the same error in Survey123 forms built into ArcGIS Dashboards. Apparently, Dashboards underwent an update during maintenance on 03/22/2022 and as a result it stopped passing the token to the embedded form, causing it to no longer load forms that are not publicly shared.

RussRoberts
Esri Notable Contributor

For Map Viewer based issues

1) I cant seem to reproduce this do you have a sample layer

2) This one also need a sample map with the bookmarked location

3) not seeing any lag with zoom, will need sample map but also what OS, browser and if your device is touch screen or not.

4) When you have a layer selected we will show only the tools that work for the layer selected. Before we would just disable the tools that were unsupported for layers now they are hidden.

5) Also not seeing this and would need a repro map

6) Same as #5

 

If you can share the samples to a group and invite russell_jsapi into it I can investigate further

0 Kudos
neomapper
Occasional Contributor

Hey @RussRoberts ,

You should be getting an invite to a Heathstone_Esri_Support group by an Esri user named Bennan. I shared our Map Viewer and dashboard there. It appears that the Form feature doesn't work either. Let me know if there's anything more I can share.

Thanks,

Jordan

0 Kudos
RussRoberts
Esri Notable Contributor

Can you rebuild the indexes on the layer not returning the popup? This can be found under the layer settings of the feature layer item. How was this item last updated bc it looks like an issue with the FL returning an ID that doesn't exist.

0 Kudos
neomapper
Occasional Contributor

Hey @RussRoberts , 

I rebuilt the indexes on the layer but we don't see any improvements. Before the update we didn't experience this issue. When we needed to update data, we would delete and append everything from within ArcGIS Pro. 

0 Kudos
RussRoberts
Esri Notable Contributor

Thanks, can you retest today? I cant seem to reproduce the popup issue with your maps yesterday

0 Kudos
neomapper
Occasional Contributor

If you open the map at the top there will be 2 layers turned off. When you turn these on it prevents all the layers from displaying a popup in the map

neomapper_0-1648136916647.png

 

0 Kudos
RussRoberts
Esri Notable Contributor

Thanks, looks to be a different issue from yesterdays one. This one I can reproduce with my own test case but it looks like its due to the itemids  for the layers you are trying to get the popup from in the web map no longer exist but the feature services are still around. Was this an intentional change?

0 Kudos
IckFin
by
New Contributor

Hello @neomapper in reference to your Dashboard comment, I am also having the same error with a Survey123 form embedded in a dashboard. Based on the comment by @DembaEstadual, I confirmed that the survey works normally after sharing both the form and it's associated feature layer publicly - but unfortunately this is not a feasible solution based on my project.