Select to view content in your preferred language

Error: Service contains unsafe html content - [Description]. Any ideas?

1810
3
Jump to solution
09-12-2016 12:03 AM
PaulDoherty3
Occasional Contributor

Has anyone else seen this error before? 

It appears when I try to publish an editable feature layer from a service URL but I cannot figure out the cause. It is a layer I published earlier from ArcGIS Pro and there is nothing special about it. If I don't find a solution tonight I will put in an Esri Support Ticket and post back here on what I find. 

KGerrow-esristaff‌?

0 Kudos
1 Solution

Accepted Solutions
KellyGerrow
Esri Frequent Contributor

As some follow up, this was caused by the following bug: BUG-000099728. As a workaround, ensure that there is no text in the description field of the Map in ArcGIS Pro when publishing.

View solution in original post

3 Replies
KellyGerrow
Esri Frequent Contributor

Hey Paul,

Is the source URL and the url with the error publicly available? If so, can you share them?

Cheers,

Kelly 

0 Kudos
PaulDoherty3
Occasional Contributor

http://eaglegis.maps.arcgis.com/home/item.html?id=935781f12be8460dba8826b5fafa1519 

http://services.arcgis.com/XTtANUDT8Va4DLwI/arcgis/rest/services/Worksite_Triage_Form_Layer_Template... 

Here are the settings on my end. I am able to use other services with no problem, but it seems to be either because I am publishing from Pro or a setting on the service / item page. 

0 Kudos
KellyGerrow
Esri Frequent Contributor

As some follow up, this was caused by the following bug: BUG-000099728. As a workaround, ensure that there is no text in the description field of the Map in ArcGIS Pro when publishing.