Enable ownership-based access control is grayed out

620
3
06-05-2019 09:23 AM
MollyFoley
Regular Contributor

I have enabled editor tracking on my feature service and when I go to overwrite the service, I still do not have the option to enable the ownership-based access control option (it is still grayed out). How do I get this to work? My workflow to get it on ArcGIS online goes like this:

1) Publish the service from ArcMap while logged in to AGO, under the "Sharing" property I share it to My Content.

2) Feature service shows up on AGO and when I view the item details > Settings there is no option for access control.

3) When I make a map with the feature service in AGO and view the item details > Settings, there is no option for access control.

Do I need to have a user defined on my server for each person that will be using this web map in Collector? I currently don't, but I don't care if it shows up as ESRI_Anonymous, as long as they're only allowed to edit their own features, I'm fine.

Tags (1)
0 Kudos
3 Replies
ClaireHofius
Esri Contributor

Hi Molly,

Is this the ownership base access control that you are hoping to enable: https://enterprise.arcgis.com/en/server/latest/publish-services/windows/ownership-based-access-contr...?

This functionality can only be used with enterprise geodatabases, not databases, and thus can only be used with Fearture Services published to ArcGIS Server, not ArcGIS Online. 


0 Kudos
MollyFoley
Regular Contributor

I am using it on an enterprise geodatabase, the services are published to Server, and then I believe I should be able to use them on ArcGIS Online given this documentation on portal https://enterprise.arcgis.com/en/portal/latest/use/enable-ownership-control.htm. You should be able to set up the ownership control when you either publish the service or after the fact (of which I can do neither because it's grayed out everywhere). So even if I can't see the settings on AGO (which I was unclear on so thanks for that), I should still be able to set it on Server, and I cannot.

0 Kudos
MollyFoley
Regular Contributor

Figured out the issue, even though it's probably not really the correct solution since in the documentation it states you can change the setting after publishing. For me, I couldn't overwrite the service with it enabled or change the setting on the Server, so I just published a new service from scratch and then I was given the option to enable it. Don't know why but it works.