Enable legend in a tile cahe in ArcGIS Online

4217
2
12-14-2015 04:20 AM
FranciscoSobrado_Llompart
New Contributor II

Dear all,

I am trying to enable the legend in a tile cache in ArcGIS Online but it does not show in the map.

I have followed these steps to create the Tile cache:

   1- Run Generate Tile Cache Tiling Scheme to define the tiling grid and image format.

   2- Run Manage Tile Cache to build the tiles.

   3- Run Export Tile Cache to create the tile package.

   4- Run Share Package (in the Package toolset) to upload the tiles onto ArcGIS Online.

Unfortunately, I con not enable the legend in the tile layer options in ArcGIS Online...any ideas?

Cheers

0 Kudos
2 Replies
RebeccaStrauch__GISP
MVP Esteemed Contributor

Is this a basemap?  From Troubleshooting help Troubleshoot—ArcGIS Online Help | ArcGIS

The map is missing a legend.

You will not see a legend for basemaps and OGC WMTS layers. You will also not see a legend for layers that are not accessible externally or that the map author has hidden.

0 Kudos
JssrRR
by
Occasional Contributor II

Francisco,

I had the same issue with legend not showing up, when I followed the steps, you did to create tile cache, but then found this blog by Yovav Zohar​  and using Create Map Tile Package, gave me the embedded legend, if you look at the table he has included, you can see which workflow has the embedded legend creation:

https://community.esri.com/people/Yovavzsystematics-co-il-esridist/blog/2014/08/26/cache-and-tpk-wit...

Tool help :

Create Map Tile Package—Help | ArcGIS for Desktop

Hope this helps