Embed Facebook page broken?

11-03-2020 02:10 PM
by Anonymous User
Not applicable

I've tried embedding several public facebook pages in either a Hub site or Experience Builder and nothing is working. Nothing will load. I'm pretty sure I did this on a hub site we had this spring for covid - I pasted the web address of the page and the timeline posts showed up, which was slick.

I cannot get this to work now. I've tried 3 different public facebook pages and everytime it just sits and shows the "loading" bar and nothing happens.

Did facebook change it's coding or something that Esri needs to update or am I missing something obvious? In the Hub site help it says: In the Social Media Post URL field, paste a URL for any publicly shared Facebook page. But it doesn't do anything.

Tags (2)
0 Kudos
4 Replies
Esri Regular Contributor
0 Kudos
Esri Contributor

Nathan Fazer‌ thanks for reaching out -- I've verified the social media card works as expected for Facebook posts and timelines in Hub.  Are you using the social media card or the iframe card within your Hub site/page layout?  Can you send along the Facebook timeline you are looking to embed?

0 Kudos
New Contributor III

I am suddenly experiencing the same problem with Facebook timelines using the Social Media Card.  This is a new issue, the site has been up for months without issue.  Everything looks good in the Hub designer and preview, but when I publish and open another browser tab, Incognito or not, on current versions of Chrome or Firefox I get a message in the cards, "Your Request Couldn't be Processed. There was a problem with this request.  We're working on getting it fixed as soon as we can." click the Close button in the windows and the loading icon just spins.

Esri Contributor

same experience. It only occurs for me, if I'm not logged into the Hub. So either incognito or logged out, getting the spinning error of death



0 Kudos