duplicate field in service

560
2
03-03-2020 07:33 AM
StuartMoore
Occasional Contributor III

has anyone see this issue before, I have a feature service and there is a field in in three times but they are identical

not sure how its happened, but I think its causing issues when I load the service into a map and try to configure the popup

i've tried to delete it in two ways using the admin rest API and 'delete from definition' I get a success result from this but the fields are still there, I then tried to delete it from the data tab in the feature service but that just sits there for an hour and when I check the data it gives another error, but it still lists the three fields, and the only way to resolve this is to add it back in using the admin rest API 'add to definition'

BTW the feature service was created from survey123 connect...

any ideas before I raise a support case

thanks

Stu

0 Kudos
2 Replies
AndrewRitchie
New Contributor III

Hi Stu, 

We just had the same issue with a feature layer, also discovered because the full list of fields couldn’t be added to pop ups. Others suggestions of resetting the field order in Desktop didn’t work - the field order was already default. Republishing didn’t work, turning fields on and off didn’t work.

what DID work, was to change the field order in the mxd and then republish the service. Having the custom field order seemed to force it to recreate the definition correctly, and all fields were available in the pop up config

cheers

Andrew

StuartMoore
Occasional Contributor III

we still have this issue and its causing me more and more issues as i need to now create a replica but it fails on the layer with the duplicate field in

0 Kudos