Custom homepage not showing for public users

545
5
05-10-2022 05:16 AM
by Anonymous User
Not applicable

We want the public to be able to access our homepage. I have switched on 'Allow anonymous access to website' in the security settings. I have started creating a custom homepage and so far, the homepage is just a title, a cover image and a text block. When I am logged into AGOL, I can see it. But if I sign out, I get a default ArcGIS Online homepage (with adverts and info about ArcGIS Online).

Is there another security setting I need to check?

Thanks for any help!

Tags (2)
0 Kudos
5 Replies
jcarlson
MVP Esteemed Contributor

What is your homepage URL?

- Josh Carlson
Kendall County GIS
0 Kudos
by Anonymous User
Not applicable

This is the homepage URL

https://meanwoodvp.maps.arcgis.com

0 Kudos
jcarlson
MVP Esteemed Contributor

It looks like it's loading legacyHomePage.html. Have you officially switched your homepage in the org settings?

jcarlson_0-1652193155717.png

 

- Josh Carlson
Kendall County GIS
0 Kudos
by Anonymous User
Not applicable

We only started with ArcGIS in July 2021 so I didn't think we had a legacy homepage. If I click Homepage under Settings I just get a link to the home page editor.  

RuthAddison_0-1652197401973.png

I think the problem only occurred after I started configuring the homepage with the editor (though I'm not 100% sure because we haven't been directing public users to the homepage yet and I'm usually signed in.)

0 Kudos
by Anonymous User
Not applicable

Thanks for your advice so far, Josh. I've read this article and it says 'All ArcGIS Online organizations created after June 30, 2020 only have the new home page, so they don’t need to transition.'

Let’s transition to the new ArcGIS Online home page (esri.com)

Do you think I should create a new question asking why our homepage is loading legacyHomePage.html?

Any further advice would be great!

0 Kudos