bug(?) in Smart Forms: changes in browser Field Maps not showing in mobile app

333
2
03-16-2021 07:13 AM
Labels (1)
John_Holbrook
New Contributor

I've put in a ticket with Tech Support but wanted to reach out to the community to see if anyone else was experiencing this issue. We're trying to forge ahead with Smart Forms in Field Maps as a replacement for Collector/Survey123, but this issue is currently making deployment impossible.

Smart Forms created in desktop web browser do not show certain initial characteristics and later changes in the Field Maps mobile app. This is inconsistent, currently happening about 90% of the time, and therefore replicable across different feature services and maps.

1) Fields marked as Required in desktop/browser Field Maps do not show as Required in the mobile app 

2) Fields with conditional visibility show in Field Maps app regardless

3) Fields added to the Smart Form simply do not appear in the mobile app. This issue also seems to be tied to the number of times you hit the Save button in Smart Forms. Fields added after the first Save will show in the mobile app, but fields added in subsequent Saves will not.

Troubleshooting steps I have tried:
1) Made sure to save changes to the Smart Form
2) Used different feature services and maps
3) Generated completely new local features and published them as fresh features services to AGOL
4) Cleared cache for the app on the mobile device, uninstalled and reinstalled the app, refreshed maps

It seems as though changes made in Field Maps desktop browser aren't making it to the mobile app-- again, about 90% of the time. I've had one work perfectly, so I know it's possible, and I know the Required fields and conditional visibility expressions can work.

I'd like to think that I'm simply missing something, but this seems like a bug. As we move from Collector to Field Maps, this is a huge issue...

0 Kudos
2 Replies
MarcusSeuser
New Contributor II

I experience the same bug. I change a template in Field Maps on the desktop, then I refresh the area and synchronize it on the mobile app and still no change. I must honestly say that Field Maps is working terribly until this point and I can only hope that there is a lot of improvement until you shut down collector since we have to make that change.

0 Kudos
MarcusSeuser
New Contributor II

Dear John,

I just found a solution for my problem, maybe you want to try it for yours. I normally use the maps with mapviewer classic, but that seemed to cause the problem with the Field Maps Mobile App. As soon as I created the map again with the same layers in the new mapviewer I was perfectly capable of displaying all fields in the smartform on my mobile. 

Best, Marcus

 

0 Kudos