ArcGIS Online: Reordering Fields in Hosted Feature Layer from Data Page

1793
4
04-23-2017 03:13 PM
Highlighted
New Contributor

Hi all, I'm using ArcGIS Online and I'm wondering if there is a way to rearrange the fields of a hosted layer file. I know you can change their order and if they're displayed or not when configuring layer attributes in a Web Map, but I'm curious if there is a way to change them in the Hosted layer file itself so that the order is reflected when the layer is imported into another map. So far I've had to reorder the fields every time I start a new map and it's become really time consuming. Any hints would be appreciated. Thanks!

4 Replies
Highlighted
New Contributor

I know this post was along time ago but I have a solution.

- Open the visualization tab of your hosted feature layer.

- Configure the pop up of the layer.

- Click configure attributes 

- Click on the field you wish to move and use the arrows on the right to move it up or down the order. 

- Once you are finished moving, hit ok 2x then save the layer.

Your reordering of fields has now been made to the hosted feature layer itself and will be maintained in any map you now add it to!

Highlighted
Occasional Contributor II

This is a lifesaver James.  Thank you! James Wright

Reply
0 Kudos
Highlighted
Occasional Contributor II

I'll just add one caveat to this. This only affects the pop-up configuration. If you were to download this feature service as fgdb, it is likely that the newly added field would be at the end of your list. This will not affect the definition of the feature service itself.

From what I can tell, it is not possible to change the order of fields in the service definition itself. Even though configuring the pop-up will generate the desired results in most cases, it won't in all. Even when using the REST admin interface, you can't use 'Update Definition' to reorder fields. You can only use 'Add To Definition' to add fields or 'Delete From Definition' to delete fields.

Highlighted
New Contributor III

While I am able to get this method to work for attribute tables in WebMaps, these settings do not carry over into a WebApp attribute table that is created from the map. 

Reply
0 Kudos