AGOL Feature Service Webhooks

4401
33
07-07-2020 02:35 AM
JoshHarris
New Contributor III

Referencing the recent blog post which has introduced webhook to hosted feature services in AGOL. I was wondering if it was possible to use this to return the updates that have been made to the feature class. 

At the moment, it will tell me when a feature has been created, but I want to be able to pull the attributes of the feature that was created.

TIA

Tags (1)
0 Kudos
33 Replies
Danielle_Journey
Occasional Contributor

@Peter_Klingman  In the dev summit presentation will you go over how to register an app in AGO, and how to get the app's client ID and client secret?  I'm trying to follow this post to set up my Integromat scenario for a hosted feature service but I'm new to all of this and need a bit more instruction.  Thanks!  

0 Kudos
Peter_Klingman
Esri Regular Contributor

Hi @Danielle_Journey - this is gone over in a lot of depth in the presentation, and it is definitely not the easiest of workflows. In the meantime - this documentation also goes over the steps of registering an app in ArcGIS Online. It's for Web AppBuilder but the steps are the same in the workflow. Integromat also has some good documentation on their Oauth2 HTTP request module that might help. This is the module where you will use the app ID and app secret obtained from the app registration. 

Hope this helps!

DerekBedarf1
New Contributor

Hi Peter,

Is there a way to use the extract changes example you have above to take the coordinates of a newly created feature and reverse geocode to a field? I'm trying to think of a way to auto-populate a field with an address derived from only a point placed on the map.

Thanks. -Derek

0 Kudos
Peter_Klingman
Esri Regular Contributor

Hi @DerekBedarf1 - this sounds possible to me. You have access to the attributes of the feature (here is the blog on how to accomplish that component), so you would need to obtain the X/Y from the edit, then chain together some HTTP modules to reverse geocode the coordinates and then update the feature or apply the edit, back into the desired field. Hope this helps!

0 Kudos
julian_svcs
New Contributor III

Hi Peter. 

I am trying to run the extract changes for an ArcGIS Online feature layer. When I try and access the job's resulting URL I get an error stating "Invalid Sync model type. syncLayers json object is required.".

Do you know what is causing this?

Thanks, Julian.

julian_svcs_0-1611282971775.png

 

0 Kudos
Peter_Klingman
Esri Regular Contributor

Hi Julian,

The one record of this error I am seeing internally indicated it was caused by a mismatch between the layerServerGens and Layers parameters in the extractChanges call.

I would make sure the same layers are referenced in each parameter (e.g. 0 in both parameters vs. 0 in one parameter and 0 and 1 in the other). If they are and you are still running into the issue, let me know and I can help get a support case going for an analyst to take a closer look at the issue. 

I hope this helps,

-Peter

0 Kudos
JoshHarris
New Contributor III

Thanks @Peter_Klingman , that's working a treat now with Oauth2. I'm noticing though I'm quite frequently getting the below error when trying to get the resultUrl. Any ideas to what could be causing/why it would be missing from the JSON module?

Screenshot 2021-02-10 at 08.37.41.png

Screenshot 2021-02-10 at 08.46.20.png

Screenshot 2021-02-10 at 08.38.00.png

RE shameless plug, when is the tech session and how can I attend?

0 Kudos
Peter_Klingman
Esri Regular Contributor

Hi @JoshHarris - thanks for the response on this and glad Oauth is working. I think you are running into that error because the result URL is still pending. I have run into this a few times too and needed to increase the time of Integromat's sleep tool to delay requesting the result URL:

Peter_Klingman_0-1612971939015.png

Re: Dev Summit session - it is a pre-recorded 30 minute demo that will be made available to conference attendees. So if you register for Dev Summit, once the event begins you can view it. 

Best,

-Peter

0 Kudos
JoshHarris
New Contributor III

Thanks @Peter_Klingman , I've increased to 30s and all seems smoother. 

On another note, should it be possible for edits in Pro to be pulled through? I've got a hosted feature service and I'm making edits to the service in Pro, but it's not triggering my scenario in Integromat. 

 

Thanks for sessions details

0 Kudos
Peter_Klingman
Esri Regular Contributor

Hi Josh,

I would expect that any editing client would trigger the webhook. I just tested this myself and may need to dig into it further/possibly get an issue logged - I am getting a 'bad request' error when I try to submit an edit from Pro on a feature layer that has an active webhook. 

  • What change types do you have configured?
  • What version of Pro are you using?

Thanks,

-Peter

0 Kudos