AGO data not show in new map viewer

1053
9
Jump to solution
03-29-2022 01:59 PM
Labels (3)
ShirleyYueLi
New Contributor III

The features don't show in the new map viewer , but show up in the classic map viewer. The map has a hosted feature layer but the data are added to a view layer with editing enabled. I can see the data in the data and visualization tab in the item description of the feature layer. If I add the feature layer to the new map viewer, nothing shows up. If i add it to the classic map viewer, everything is fine. Any suggestions are appreciated!

0 Kudos
1 Solution

Accepted Solutions
mlong_ess
New Contributor II

If you briefly enable editing on the view layer, can you check the settings to see if that "Editors can only see their own features (requires editor tracking)" setting is turned on? That setting wouldn't show up in the Settings tab until editing is enabled, although the settings had been set previously (when editing was enabled) are still applied through the backend.

View solution in original post

9 Replies
RhettZufelt
MVP Frequent Contributor

Seems when I add a new layer to the classic map view, it displays the extent of the data.

When I add data to the new map view, I often have to hit the "Home" button to zoom the viewer to the extent of my data. (Or, click the three dots next to the layer and select Zoom To)

Have you tried this to ensure that the data isn't just "off the map"?

R_

 

0 Kudos
ShirleyYueLi
New Contributor III

Thank you for the quick response! i tried to open the table of the feature layer and it was empty. 

0 Kudos
ShirleyYueLi
New Contributor III

i also found if i changed the sharing level of feature layer to 'owner', it appeared on the map. The map is shared with public

0 Kudos
mlong_ess
New Contributor II

Hi Shirley,

 

Do you have ownership based control set for this view layer? https://doc.arcgis.com/en/arcgis-online/manage-data/manage-editing-hfl.htm You may want to check the setting of "What features can editors see?" specifically, to see if it is set to "Editors can only see their own features (requires editor tracking)".

0 Kudos
ShirleyYueLi
New Contributor III

Thank you for the suggestion! This layer is shared with public and editing is not enabled. I found if I share it with the organization, it would appear in the map. 

0 Kudos
mlong_ess
New Contributor II

If you briefly enable editing on the view layer, can you check the settings to see if that "Editors can only see their own features (requires editor tracking)" setting is turned on? That setting wouldn't show up in the Settings tab until editing is enabled, although the settings had been set previously (when editing was enabled) are still applied through the backend.

ShirleyYueLi
New Contributor III

This trick works!! I enabled editing and turn on editors can see all features, and then turn off editing. Now all the features appear on the map. Thank you so much!

0 Kudos
mlong_ess
New Contributor II

Wonderful, I'm glad to hear it!

0 Kudos
GloriaDesanker
New Contributor II

So if I'm understanding this correctly, "Editors can only see their own features (requires editor tracking)" should be checked off? And "Enable editing" should be turned back off? I have tried this and it's not working for me still.capture 2.PNG

0 Kudos