Access to ArcGIS Notebooks

401
10
Jump to solution
10-05-2020 12:52 PM
New Contributor

Hi, I'm getting this error when trying to access Notebook online: An ArcGIS Notebook Server is not currently configured.

I'm using ArcGIS for Personal Use. Please help!

Tags (1)
Reply
0 Kudos
1 Solution

Accepted Solutions
by Esri Contributor
Esri Contributor

Hey Andry - I see there isn't any hosted content yet in your organisation. This means it hasn't yet been assigned a services hive (Notebooks are hosted services). Try publishing a service (Content Tab -> Create -> Feature Layer -> Select a template (i.e. AEDs)). Once you've been assigned a hive, you should be able to access notebooks.

Let me know how it goes.

Josh

View solution in original post

10 Replies
MVP Frequent Contributor

Are you using arcgis Pro?  There is some discussion in the help

Notebooks in ArcGIS Pro—ArcGIS Pro | Documentation 


... sort of retired...
Reply
0 Kudos
New Contributor

Yes, but there's no issue with using it in Pro. It works very well there. However, if I try to open Notebook online in arcgis.com or if I upload my local *.ipynb to my online content then I have the error above when trying to open/preview it.

Reply
0 Kudos
by Esri Contributor
Esri Contributor

Hi, how long have you been experiencing this? We do allow notebooks on a personal use subscription. Sometimes a notebook environment will fail to initialize - if you wait a short amount of time (10-15 minutes) and try again it should work. If not please let me know and I'll look into it.

Josh

Edit: I just saw your response to another thread on this. So you've been experiencing this for a few days it seems. 

Reply
0 Kudos
New Contributor

I occasionally tried the online version since last week but it hasn't worked yet. I just tried right now, and there's still the error.

Reply
0 Kudos
by Esri Contributor
Esri Contributor

If you can provide the subscription ID for your organisation (Click the organisation tab at the top of the page and you should see it in the top left panel) I can look into things further.

Josh

Reply
0 Kudos
New Contributor

Hi Josh, I just wanted to follow up if there has been any fix for this.

Reply
0 Kudos
by Esri Contributor
Esri Contributor

Hi Andry, sorry for the delay and for the inconvenience. No solution yet but I am still looking into it. Will update you with info as soon as I can. 

Josh

Edit: Could you provide me the admin username for this org?

Reply
0 Kudos
by Esri Contributor
Esri Contributor

Hey Andry - I see there isn't any hosted content yet in your organisation. This means it hasn't yet been assigned a services hive (Notebooks are hosted services). Try publishing a service (Content Tab -> Create -> Feature Layer -> Select a template (i.e. AEDs)). Once you've been assigned a hive, you should be able to access notebooks.

Let me know how it goes.

Josh

View solution in original post

New Contributor

Now, it's working! Thanks!

Reply
0 Kudos