Route Not Working - Edge Connectivity Issues

04-06-2016 08:15 AM
New Contributor III

I am having an issue with my network dataset. I am trying to model on-ramps to interstates, and I can't seem to get the model to route me onto the on-ramp itself.

The blue arrows show that the street with F_ELEV and T_ELEV = 0 has travel in both ways. The junction between the red arrows is both a mid-vertex for the main street and a coincident from-node for the on-ramp. The on-ramp has a F_ELEV = 0 and a T_ELEV = 1 (the interstate it connects to has a logical elevation value of 1). However, when I try to run a route analysis on this, I get an error saying there is no way of doing this.

A few things I have tried:

1. I have changed the connectivity policy from endpoint to anyvertex.

2. I have placed the 1st stop on the on-ramp itself and put the second onto the interstate and the route works, showing me that the connection between the interstate vertex and the to-node of this on-ramp are connected.

3. I have tried to dissolve the network and integrate the network - the first option made no difference and the second destroyed my data (I made a copy just to be safe, and set the tolerance very low).

As you can see by the images below, it's obvious it's a connectivity issue, since all these routing situations work:

Note: Red "X" marks the junction in question:

I don't understand why it won't connect. Just to be clear, I am rebuilding the network dataset after every change I make to ensure that the changes I've made make it into the network dataset. Can somebody point me in the right direction, perhaps?


I have also tried using the Snap tool, setting the inputs to the Street Centerline and snapping it to the vertex with a tolerance of 0.5 meters (which should be more than close enough for what I am doing). When using the Network Identify Tool, I get this for the junction supposedly connecting the two edges:

As you can see, the junction seems to identify both edges using the tool, but it only shows the adjacent edge as 645 (the lower edge in the image) and the route still does not work.

I've also created a topology, adding the rule "Must Not Have Dangles", and after validating, I get no point errors at this junction.

0 Kudos
0 Replies