Peculiar behaviour while conducting a location-allocation exercise

01-24-2012 04:23 AM
New Contributor III
This exercise is the precursor to a much larger project but I thought I'd start with a more manageable dataset and build from their.

I have a roughly 16 mile square with potentially 900 facilities and 990 demand points.  I am using the location-allocation tool in NA with Problem Type: Maximize Coverage; Facilities to Choose: 18, Impedance Cutoff: 1800, Impedence Transformation: Power and Impedance Power: 1.  The result I am getting is fairly sensible except for the unexpected clustering of two or three 'Chosen' facilities within each other's catchment.  I am also getting demand counts with a huge range (from 8 to 97 in the case of 20 chosen facilities and 8 to 156 in my 18 facility option.  I've had the data set tried on a different computer and it works as expected but when I do it on my machine (running XP proff. ArcGIS10 svpk 2) I get this weird behaviour.

Has anybody else had this experience?  Any suggestions as to what I should do totroubleshoot/fix it?  Any advice greatly appreciated!
Tags (2)
0 Kudos
2 Replies
Esri Regular Contributor
Do note that that Location-Allocation is not trying to balance all choosen facilities with the same amount of demand, so each facility can have a wide range of demand points assigned to it.

However, you should not get two different solutions on the same data/problem on two different machines.

If you are geting different behavior then it could be a difference in the underlying network dataset (restrictions, impedance, etc)
or the locations are not correct. By that I mean you may have loaded the locations using "network locations" instead of geometry when in fact the network locations have become stale. You could create a new Location-Allocation layer on your problem layer, re-load the locations making sure to check on the Use Geometry and not the Use Network Location Fields and re-solve.

If this does not solve the issue, then perhaps you can post a screen-shot of what you are getting.

Jay Sandhu
0 Kudos
New Contributor III
Thank you Jay for the reply.  After much consultation with ESRI's excellant tech support it was determined that a re install of the software was required.  Once that was done everything worked as planned.
0 Kudos