network analyst solve route error search tolerance

281
1
07-05-2019 02:07 AM
robertkalasek
New Contributor III

i am trying to switch over to "arcgis pro" ... and i have done some tests on differnt kinds of network analyses (route, OD, service area). each of them worked fine in arc map based on the identical set of input data.

when it came to testing route solver i have got an error message 030212 in arcgis pro, which indicates that the start and/or end points couln't be related to the network.

calculate locations and increasing the "search tolerance" parameter didn't help at all (yes i did run the add locations-commad with "use network location fields" parameter selected !)

the same set of input-data works fine in arcmap with the route-layer properties / network locations / search tolerance set to 1000m.

by the way: does anybody know how to restrict network entry points ... which is done in arcmap via route / layer properties / network locations / finding network locations / snap to - settings.

thx in advance

robert

Tags (2)
0 Kudos
1 Reply
JaySandhu
Esri Regular Contributor

You mentioned that you used Add Locations with the "use network location fields" parameter selected. 

This means you are telling Add Locations to skip the geometric searching. The network location fields are most likely stale and that is why the start/end points are not being located. You should use the "Use Geometry" instead with the Add Location and the stops should be located. 

Network Location fields can become stale if you edited/re-built your network or are using a different network then the one on which the fields are computed. Network Location fields make it faster to add stops to network analysis layers but you have to recompute them if/when the network changes.

Jay Sandhu

0 Kudos