Network Analyst - Service Area problem (ArcGIS 10.4.1)

842
6
Jump to solution
10-03-2018 01:05 PM
AmirhassanKermanshah
New Contributor II

Hi everyone!

This is the first time I'm getting this problem and I have no idea what is the main problem with it. I'm trying to find 5 km or 10 km service area around emergency stations before and after a flood. But it seems that the ArcGIS prefers to go only on one direction in the road network rather than finding the service area in all possible directions.

I was wondering how can I solve this issue.

Thanks,

Amir

0 Kudos
1 Solution

Accepted Solutions
JaySandhu
Esri Regular Contributor

TIGER is not a good source for routing as it lacks essential speed/travel time type fields to make a good network. Also the default network dataset connectivity is "End Point". Change it to Any Vertex and rebuild the network dataset. See screen shot below. This will work as long as the long roads have a vertex wherever other lines cross or connect to it. If it still does not work then it means the data needs to be "integrated". In that case run the GP tool "Integrate" and then use the Any Vertex option and rebuild the network. Integrate—Help | ArcGIS Desktop 

Jay Sandhu

View solution in original post

6 Replies
JaySandhu
Esri Regular Contributor

What network dataset are you using? Is it something you built yourself? What is the source of the data?

Service areas go in all direction until they can't! So if it appears they stop too soon then it could be disconnected network or a restriction stopping travel on that road.

On the NA toolbar, the second from the right icon is the network identify tool. Use it to click on the roads where the polygon stopped and see if those roads are "connected" to the roads that are not covered by the polygon.

AmirhassanKermanshah
New Contributor II

Thank you very much Jay!

The data that I'm using is from TIGER shapefiles and is for a county in TN, USA. I think the problem as you said is with  the way that ArcGIS made the network dataset out of the main road shapefile. It seems that it didn't divided the big segments of the road (figure attached).

Do you have any suggestions that how can I solve this issue? 

Thanks again,

0 Kudos
JaySandhu
Esri Regular Contributor

TIGER is not a good source for routing as it lacks essential speed/travel time type fields to make a good network. Also the default network dataset connectivity is "End Point". Change it to Any Vertex and rebuild the network dataset. See screen shot below. This will work as long as the long roads have a vertex wherever other lines cross or connect to it. If it still does not work then it means the data needs to be "integrated". In that case run the GP tool "Integrate" and then use the Any Vertex option and rebuild the network. Integrate—Help | ArcGIS Desktop 

Jay Sandhu

AmirhassanKermanshah
New Contributor II

Great!

Thanks for your great suggestions.

0 Kudos
ChrisDonohue__GISP
MVP Frequent Contributor

What Jay Sandhu suggested will likely cover it.  But if there still is an issue, check to see if the problem area streets are attributed as 'one-way".  I've several times seen data goofs where street segments were attributed as one-way when they are actually two-way (and vice versa).

Also, check the other Network Attributes.  Look for weirdness, like a Speed of zero.

If you are modeling one-way streets, be sure that your edge sources have a field specifying one-way street information. The New Network Dataset wizard recognizes a string field named One_Way or Oneway, creating evaluators that interpret its values as follows:

  • FT or F indicates a one-way street permitting travel only in the digitized direction of the edge.
  • TF or T indicates a one-way street permitting travel only against the digitized direction of the edge.
  • N indicates a street that does not permit travel in either direction.
  • Any other value indicates a street that permits travel in either direction.

Creating a network dataset—Help | ArcGIS Desktop 

Chris Donohue, GISP

AmirhassanKermanshah
New Contributor II

Great information! Thanks Chris

0 Kudos