Network Analyst License Error

1202
10
08-22-2011 04:58 PM
Highlighted
New Contributor
I'm trying to create Network Analyst Dataset so that I can do some routing, but when I attempt to run the "Build Network" tool in Catalog I get the attached error.  You can also see in the screenshot that Network Analyst is authorized.  What's the problem here and how do I fix it?

Thanks,

James
Reply
0 Kudos
10 Replies
Highlighted
Regular Contributor III
Hey James,

Have you checked the Network Analyst extension in the Extensions window? Main menu > Customize > Extensions.
Reply
0 Kudos
Highlighted
New Contributor
That fixed it, thanks Alex.

Seems like the error message is incorrect though as a point of feedback.

Thanks,

James
Reply
0 Kudos
Highlighted
Regular Contributor III
You are welcome, James. I agree that it might be not that easy to guess that one should go to the Customize menu to activate the extension. On the other hand, though, there is information about this on the help page which is very easy to find. 🙂

http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/Using_Extensions_in_ArcGIS/00r90000001...
Reply
0 Kudos
Highlighted
New Contributor
Absolutely, I was just making the point that the "your license doesn't support this extension" message is incorrect.  It should say "You have not enabled this extension" or something.
Reply
0 Kudos
Highlighted
Regular Contributor III
James, it does actually - this is the last row in the error message! 🙂
Reply
0 Kudos
Highlighted
New Contributor
*forehead to desk*.  Doh.  I guess I got thrown off by the first line.
Reply
0 Kudos
Highlighted
Regular Contributor III
Keep you head up, mate! 😛

Happy testing!
Reply
0 Kudos
Highlighted
New Contributor III
I had the same issue with the Maplex extension, thanks for posting! Its not intuitive for me since I am currently using 9.3.1 and do not have the toolbars/extensions options. I just figured because I couldn't see Maplex or 3D Analyst under Customize -> Toolbars it wasn't installed but when I tried to go back and re-install the 'missing pieces' they were already installed.

Is this the case in version 10, too?
Reply
0 Kudos
Highlighted
Regular Contributor III
Hey Kitty,

I am not quite sure what your problem is. Could you please clarify what exactly do you try to achieve and what issues do you face?
Reply
0 Kudos