Service Area errors

5900
4
09-21-2011 01:37 PM
Highlighted
New Contributor
I'm running a service area operation in NA and I'm receiving the following error.  No service area polygons are created.  I'm using the StreetMap 9.3 network dataset in ArcView 9.3.  My locations are centroids I created from a TAZ polygon file.  If I try to run all 4,600 points it just bails with no error message.  Using just 1,000 point I get the following error.

Warning: Location "Location 2" in "Facilities" is on a non-traversable network element.
Warning: Location "Location 9" in "Facilities" is on a non-traversable network element.
Warning: Location "Location 12" in "Facilities" is on a non-traversable network element.
Warning: Location "Location 95" in "Facilities" is on a non-traversable network element.
Warning: Location "Location 163" in "Facilities" is on a non-traversable network element.
Warning: Location "Location 260" in "Facilities" is on a non-traversable network element.
Warning: Location "Location 378" in "Facilities" is on a non-traversable network element.
Warning: Location "Location 747" in "Facilities" is on a non-traversable network element.
Warning: All network edges were excluded from line/polygon generation for "Location 2" in "Facilities".
Warning: All network edges were excluded from line/polygon generation for "Location 9" in "Facilities".
Warning: All network edges were excluded from line/polygon generation for "Location 12" in "Facilities".
Warning: All network edges were excluded from line/polygon generation for "Location 95" in "Facilities".
Warning: All network edges were excluded from line/polygon generation for "Location 163" in "Facilities".
Warning: All network edges were excluded from line/polygon generation for "Location 260" in "Facilities".

Anyone have any ideas what is going on here.  Thanks in advance!

Max
Tags (2)
Reply
0 Kudos
4 Replies
Highlighted
MVP Esteemed Contributor
Often times error messages are pretty vague. These seem pretty specific. Go to any of the locations listed in the error and with the network inspection tool poke around and see if there are any problems with connectvity. If an element is non-traversable there is a reason for it.

Does it have a barrier?
Is it restricted due to an evaluator?
Is it disconnected from the network?

You might also make sure that your taz centroids are within the specified tolerance to be considered as a network element.

Hope this helps-
Reply
0 Kudos
Highlighted
Esri Regular Contributor
How big is your service area break? It is likely that you are not getting any output as the solver may have run out of memory trying to solve for such a large number of locations.

You can either solve for smaller set or use the idea of "chunking" or setting up a registry key to tell the solver to solve a few at a time and write them out. You can follow the directions here:
http://support.esri.com/en/knowledgebase/techarticles/detail/38426

As far as the other messages about non-traversable, your facilities are getting located on restricted edges. You could take a look at the restrictions that are on and turn some of them off (if permitted) or locate these locations some other nearby streets.

Regards,
Jay Sandhu
Reply
0 Kudos
Highlighted
New Contributor
Thanks for the input Joe, I will look into these possibilities.  I'm also getting the error
"Error: The geometry is not Z-aware"

Any ideas?

Max
Reply
0 Kudos
Highlighted
Esri Regular Contributor
Most likely you are out of memory due to the large number of facilities/break value you are using.
See the following for simillar issue:
http://forums.arcgis.com/threads/3370-Network-Analyst-Error-The-geometry-is-not-Z-aware

Jay Sandhu
Reply
0 Kudos