How do I fix receiving "<Monitor server> says null" when running Report>Excel?

190
2
05-10-2021 06:57 AM
Makeel
by
New Contributor

We are about four months into use of Monitor and recently started using the Report>Excel file output process. Early on we explored its use when we had yet to setup full collections, and we didn't have any issues. However, we're now seeing the "null" process crash message for every attempt running the process on a timeframe greater than half a day. 

We have repeat behavior on multiple Monitor application servers (Test/Prod), collections, and with multiple browsers (Edge/Chrome). Another detail which may or may not be useful; there appears to be a 30 min. threshold which causes, or is coincident, to the failure. 

What are we missing to reach our goal of capturing weekly reports to file?

0 Kudos
2 Replies
KjellTimalm
New Contributor III

Hi Makeel

I had the same problem some time ago when I wanted to generate weekly reports for my ArcGIS environments. I also had this "timeout" after 30 minutes.  It seems that there are too much data to handle and this takes to long to generate (30 min timeout). When I just generated a report for some hours it worked because this didn't take too long to generate.

Either you have too have less counters in ArcGIS Monitor so you doesn't generate so much data or split into several collections if there are many servers.

My workaround was to use the addon for generating Excel-reports. There I could choose exactly what information should be in the report and therebye get less information. But it was able to generate a weekly report with the information I was interested in. But still a workaround.   

0 Kudos
Makeel
by
New Contributor

Thanks for the reply.

I, too, explored the same workaround, though I expect the data we wish capture would vary enough to periodically over-run the 30 min. time limit. Having to monitor the Monitor reporting would defeat the purpose of setting the automation.

If a time limit of 30 min. is applied to the task, there should be an editable setting somewhere, rather than hard-coding to the Monitor application. Fixing a 30 min. cap is too arbitrary.

0 Kudos