Automate Monthly Monitor Reports

493
2
Jump to solution
02-04-2020 06:15 AM
JoeWilks
New Contributor II

Hi,
I was looking at how to automate monthly reports from the API in Monitor.

On the face of it, it seems straightforwards enough with the REST URL, for example -

https://<ServerName>/rest/api/monitor/availability?token=<token>

then the POST body which would be (if I followed the API page on the Monitor Webpage)

{ "where": { "collectionId": ["<ID>"], "startTime": <StartMilliseconds>, "endTime": <EndMilliseconds>} }

My question is -

Has anyone set this up to be automated, and used it successfully?
If so, did you need to configure the Token to be generated each time? And Are you able to shed any light on how you were able to set it up?

Ideally I'd like to be able to have a script that could run at the end of each month, grab the stats for just the CPU and RAM, and export those into an Excel Report.

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
MichaelReither
New Contributor III

The best way to automatically generate a monthly ArcGIS Monitor report is to download and configure the "Excel Report Task Add-on" from the ArcGIS Monitor Gallery.  Here is the download link:

https://www.arcgis.com/home/item.html?id=4cbc1aa1d147459380aa080224303214 

This Add-on, when run as a monthly task within ArcGIS Monitor, will generate a Monthly Report in Excel format. Follow the instructions in the PDF file within the download to configure this Add-on.

View solution in original post

0 Kudos
2 Replies
MichaelReither
New Contributor III

The best way to automatically generate a monthly ArcGIS Monitor report is to download and configure the "Excel Report Task Add-on" from the ArcGIS Monitor Gallery.  Here is the download link:

https://www.arcgis.com/home/item.html?id=4cbc1aa1d147459380aa080224303214 

This Add-on, when run as a monthly task within ArcGIS Monitor, will generate a Monthly Report in Excel format. Follow the instructions in the PDF file within the download to configure this Add-on.

0 Kudos
JoeWilks
New Contributor II

Hi Michael, thanks for that. I got it working and it seems to only run intermittently. By that, I mean

1) The 403 error described by a user here - which I have followed the remedy to (grant admin use within Monitor) but it isn't always reliable - https://community.esri.com/thread/213797-gallery-extension-issues-with-authentication-403 

2) It only seems able to export to the location in the default Config file. Any custom location it doesn't like

0 Kudos