ArcGIS Monitor Email Alerts

1132
8
Jump to solution
12-19-2018 07:02 AM
AlbertoOrdoñez_García
New Contributor III

Hi,
We are not receiving mail alerts from ArcGIS Monitor. We succesufully configured Mail notifications using config.db file and also Test Email function is working fine. There isn't any comunication problem between the mail account defined in the config.db file and target email. Please find attached email.log, emailDynamic.log and config.db file.
 Any idea?

Thank you.

0 Kudos
1 Solution

Accepted Solutions
AndrewSakowicz
Esri Contributor

To  follow up, Esri Tech Support was able to determined this problem was related to SMTP error, not ArcGIS Monitor.

View solution in original post

0 Kudos
8 Replies
ScottFierro2
Regular Contributor

Will be helpful for people to know which version you are using?

Are you saying zero emails work or just sub-group specific emails?

I can say that as of the 10.6 release we identified a BUG with the email notifications but its specific to segmenting alert emails based on the types. In this version if you designate a person to receive "All" email notifications they will get the alerts. If you choose to only send "DB" specific email alerts they will never get an email although they should get DB triggered alerts. I don't recall off top of my head but I believe we worked with ESRI and identified there are 3 of these sub classifications that will never work and send an email. I can't say if this has been fixed yet and our workaround was to spam interested staff with ALL emails and use Outlook rules to parse keywords. Allows staff to check just the folder with their alerts at least but still not pretty.

AlbertoOrdoñez_García
New Contributor III

Sorry Scott, version is 10.6.1. And i set one specific mail to receive "All" notifications. There are some errors in the logs i attached.

Thank you.

0 Kudos
ScottFierro2
Regular Contributor

OK, and we are at 10.6 so maybe a version specific issue. I re-did a test just now and can confirm at 10.6 the DB specific email alerts don't work but also verified that putting users into the "All" group persists that behavior. Meaning regardless of things working no email alerts will ever get sent for alerts tied to the database. Didn't have time to vet what the other tabs are but know from the support case we opened we determined at least 1 but maybe 2 other tabs with this behavior. Sounds like your issue may be slightly different and for security reasons we can't pull down ZIP files to try and quickly look and see if anything stands out in your info or not. Hopefully tech support is able to get you some answers soon.

0 Kudos
ShreeRajagopalan
Esri Contributor
AlbertoOrdoñez_García
New Contributor III

Hi Shree,

i opened a case in Technical Support on November 12th and still no solution, workaround or idea, that's why i am trying to find any possible solution here.

I really appreciate any help with this problem.

Thank you.

0 Kudos
ShreeRajagopalan
Esri Contributor

Alberto Ordoñez García‌ - I just received an update that tech support has escalated this issue and are looking into it. Will keep you posted.

0 Kudos
AndrewSakowicz
Esri Contributor

To  follow up, Esri Tech Support was able to determined this problem was related to SMTP error, not ArcGIS Monitor.

0 Kudos
AlbertoOrdoñez_García
New Contributor III

Hi Andrew,

As we talked to Technical Support, in our ArcGIS Monitor deployed on AWS, Test Mail function is working fine, please see attached images:

ArcGIS Monitor Email configuration

Succesfully execution of Test Mail

Office365 trace log showing Test Mail execution 

When an alert is triggered there is not activity in Office 365. We have also deployed ArcGIS Monitor internally (on premise) with the same SMTP and everything works fine.

On AWS Instance where ArcGIS Monitor is installed we oppened all traffic in Windows Firewall and in Security groups with no luck.

Francisco Manjarrez‌ 

Ana Belén Barral Rojo

Fernando Martín Verbo

Thank you.

0 Kudos