ArcGIS Monitor 10.7.1 login problems

2491
18
Jump to solution
10-14-2019 02:58 AM
ErikLanhammar
Esri Contributor

Hello,

I just installed ArcGIS Monitor locally on a DELL Precision 5530 CORE i9 laptop with W10 Pro 32 GB RAM.

ArcGIS Monitor Administrator seems to work fine, I can create Collections, Counters etc but I cannot log into the ArcGIS Monitor Server Application web UI: https://<mymachine_fqdn>:444...

At first it seems ok after entering credentials (Site/mypwd) and hitting enter, the screen flickers and it kind of looks like the login succeedes, but I end up back on the login page... Looking in the Network trace I get a 'Bad Request' for URL: https://<mymachine_fqdn>:444/rest/api/monitor/statusSummary 

Any Ideas?!

Rgds,

/Erik

0 Kudos
1 Solution

Accepted Solutions
FrankPizzi
Esri Contributor

The problem is the current version of MongoDB is not compatible.  Please check the documentation and download the supported version of MongoDB.

View solution in original post

18 Replies
SteveStansfield
New Contributor II

We are having the exact same issue here. I installed ArcGIS Monitor 10.7.1 last week but cannot log in to the web application with the same "400 Bad Request" error https://...../rest/api/monitor/statusSummary 

0 Kudos
ErikLanhammar
Esri Contributor

Thanks, for posting Steve. I forgot to mention: I did import a "real"  CA (Digicert) signed ssl-certificate into ArcGIS Monitor and hence no SSL warning in the browser, but still having the issue.

/E

0 Kudos
SteveStansfield
New Contributor II

We have not yet created a real cert so I was wondering if that was causing issues but it’s good to know that is not part of the issue. I have opened as case with Esri for this as well as another problem I’m having and that is not being able to even get the login screen from outside the server. I’m guessing that is a firewall issue but I’m not a networking person and asked for the exact wording I have to send to our networking group.

Steve

0 Kudos
ErikLanhammar
Esri Contributor

I have two inbound firewall rules defined: allow tcp 444 and allow tcp 27017

/E

0 Kudos
SteveStansfield
New Contributor II

That was a little confusing to me. I saw the following for the requirements:

We didn’t have anything on 443 so I was assuming it would use that but it might need to be opened. I thought 27017 would be used internally on the server but maybe I’m wrong. I’m mostly a programmer guy but got thrown in to the admin role a few years ago so I’m not really familiar with how all the firewall rules work.

0 Kudos
ErikLanhammar
Esri Contributor

Usually you dont have to define a inbound FW rule for the standard ssl port 443 but you probably need to if you want to use another port for ssl. Re the FW rule I have defined for MongoDB (27017), I just disabled it and things seem to work fine anyways. I guess the main thing here is to make sure ports you will use (ie whats in the ArcGIS Monitor post-install) are not occupied by any other processes. Check with netstat -ano or netstat -an | find "<portnr>".

/E

0 Kudos
MattD
by Esri Contributor
Esri Contributor

Hey Erik, 

What version of MongoDB are you running with ArcGIS Monitor? I have seen this issue before when an unsupported version of MongoDB is used, most notably with 4.2x. Please confirm the MongoDB version, and if necessary install with a supported version of MongoDB (4.0 or below). 

ArcGIS Monitor system requirements—Installation Guides | ArcGIS Enterprise 

ErikLanhammar
Esri Contributor

Hi Matthew,

Following the workflow there are no {"date": entries in the latest generated file. No occurrence of 'error' either...

 

Yes the service is running.

/E

0 Kudos
ErikLanhammar
Esri Contributor

Hi Joshua, yes Im using 4.2.x. Will re install "everything" and keep you posted!

/E

Mvh,

/Erik

0 Kudos