Select to view content in your preferred language

Imagery not showing, but elevation is

476
3
06-21-2022 02:38 PM
Vic_2022
New Contributor

Hi,

I'm evaluating ArcGIS, and I have an issue. For some reason imagery is not showing. Elevation data and building data is loading though, and the API key is set correctly. The routing api is also working correctly, so I am not sure what the issue could be.

There are no errors, and the logging component does not mention a problem, except for a warning with a propagated error. This error is also mentioned in the release notes:

  • View state report propagated warning messages

    Summary: When you get the error message by using the view state report, propagated error messages are logged in the Console although it's not an error.

    Workaround: No workaround available.

I am not sure what this means exactly, both the release notes and the console do not give me any direction to solve the issue. Anyone have any ideas why ArcGIS would show everything but not the imagery? 

Thanks,

Vic

0 Kudos
3 Replies
Matt_Nelson
Esri Contributor

Hi Vic, 
Can you provide any more information such as platform, os version, unity version? And have you tried with other imagery sources as well?

0 Kudos
Vic_2022
New Contributor

Hi Matt,

Thank you for the quick reply. Extra information. I tried it with multiple combinations:

- 2022.1.5f1. with URP

- 2022.1.5fs with HDRP

- 2021.3.4f1 LTS with URP

- 2021.3.4f1 LTS with HDRP

My OS is Windows 64 bit, my Graphics Card is a Nvidia 770 GTX, I have also created a build, same result as from the editor.

I have tried multiple image sources, but none work. I have not checked yet if there are actual calls to the endpoint, but i do know no textures are setup in the materials, except for the elevation texture. I don't know if there is some way to get lower level debugging information from the library to validate if the calls are working, i could snif the packages i guess..

Another thing I noticed is that it might be a localization issue in the tiling code? I had to adjust the routing example code to get the routing working, because the string interpolation code $"{long}, {lat}" would localize the floats using my dutch settings, so instead of adding for example 40.70 to the string, it would add 40,70. This would result in an error in the example. It might be that there is similar low level code within the imagelayer/basemap code, but I can't validate since I don't think it is open source/C#. To be clear, i made this adjustment in the routing example:

private string GetRouteString(GameObject[] stops)
{
ArcGISPoint startGP = stops[0].GetComponent<ArcGISLocationComponent>().Position;
ArcGISPoint endGP = stops[1].GetComponent<ArcGISLocationComponent>().Position;

string startString = $"{startGP.X.ToString(CultureInfo.InvariantCulture)}, {startGP.Y.ToString(CultureInfo.InvariantCulture)}";
string endString = $"{endGP.X.ToString(CultureInfo.InvariantCulture)}, {endGP.Y.ToString(CultureInfo.InvariantCulture)}";

return $"{startString};{endString}";
}

 I haven't tested my setup on another pc yet, hopefully i can do that today.

0 Kudos
Matt_Nelson
Esri Contributor

Hi Vic, sorry for the delay we were busy with the Unreal Engine release and the User conference last week but I didn't forget about this question. 

The unity version/build info seems perfectly fine to me. I do have some concerns with the 770 there is potential the the texture format is not supported by that hardware/drivers. 

That is good to know about the routing sample that is not something we considered so I'll try to get that updated when I have time.

I'll see if I can gather some more information on this and get back to you but I would suspect the localization issue isn't an issue for our tile fetching code. If you wouldn't mind could you change your localization settings and try again?

0 Kudos