Select to view content in your preferred language

UniqueValueRenderer not dispalying anything

423
2
11-29-2022 10:12 AM
Guy_srb
New Contributor III

Hi 🙂

recently I've tried to use the UniqueValueRenderer with UniqueValueInfo category to display various symbols on the map(using a feature layer).

when I try to use the renderer I get this error:

Guy_srb_0-1669745258592.png

and in text:

 

[esri.views.2d.engine.webgl.mesh.templates.WGLTemplateStore]

  1. {name: 'mapview-template-store', details: a, message: 'Unable to fetch requested texture resources'}
    1. details: {name: 'TypeError', details: {…}, message: "Cannot read properties of undefined (reading 'markerPlacement')"}
    2. message: "Unable to fetch requested texture resources"
    3. name: "mapview-template-store"

 

I didn't manage to find anything usefull in google about this error.

the symbols that I am using are picture-marker(when I tried to use one of them in a simple renderer it worked..so I don't think there is something worng with the images.

 

 

thanks!

 

0 Kudos
2 Replies
ReneRubalcava
Frequent Contributor II

If you have a basic codepen or github sample with the error, could take a look. Can't tell much from the error.

0 Kudos
KristianEkenes
Esri Regular Contributor

A codepen or similar app would help debug this. On the surface it seems like an issue with PictureMarkerSymbol.

0 Kudos