Blurry photos and PNG (instead than jpg) download in Attchment viewer Instant App

830
15
Jump to solution
04-11-2022 08:25 AM
Labels (1)
RobertoRossi
Occasional Contributor

Using the workflow suggested in ArcWatch article Add Geotagged Photos to ArcGIS Online Web Maps, I created this Attachment viewer App (https://arcg.is/0K5KiW) in order to browse the photos, using the Attachment focused option and the Image downloads options. I used MapViewer classic.

I have the following issues

  • photos are blurry
  • the zoom tool doesn't work
  • the download button (low right) starts a PNG download, instead than the original JPG file

Can anyone help me?

Roberto Rossi

0 Kudos
1 Solution

Accepted Solutions
RyanLibed
Esri Contributor

Hi Robert,

In the June 2022 ArcGIS Online update, the image zoom slider and download issues have been addressed. Please let me know if you still see issues. 

Thanks,
Ryan

View solution in original post

0 Kudos
15 Replies
RyanLibed
Esri Contributor

Hi @RobertoRossi,

Posted answers to your post down below in red:

  • photos are blurry
    In the near future, there are plans to enhance Attachment Viewer's media viewer and this is something that we can look into. 
  • the zoom tool doesn't work
    Thank you for reporting this! I will get an internal issue logged and addressed at the next ArcGIS Online update. 
  • the download button (low right) starts a PNG download, instead than the original JPG file
    This is interesting because when I use the download button in your sample app, the file is downloaded in the .jpg file format. 

Best regards,
Ryan Libed

 

0 Kudos
RyanLibed
Esri Contributor

@RobertoRossi ,

Taking a second look at the zoom tool, it appears that the image zoom tool slider is working on my end. 

https://unipd.maps.arcgis.com/apps/instant/attachmentviewer/index.html?appid=e8679c5397e24093b9552ed...

I tested the app in incogonito and it appears to be working ok. Please let me know if is still not working for you. Can you try testing the app in incognito mode?

Thanks,
Ryan

0 Kudos
RobertoRossi
Occasional Contributor

Hi @Ryan thank you very much for your feedback.

I tested the app in incognito using Mozilla Firefox, Microsoft Edge and Google Chrome.

With all the 3 browsers, the zoom tool slider works for the first 3-4 photos. If I continue to browse the photos, or move to another picture using one of the points on the map, the slider stops to work.

A curious behaviour in Microsoft Edge and Google Chrome is that the download tool in these 2 browser apparently downloads a JPG, but if I open the file I discover that it's a PNG renamed with JPG extension.

Maybe also in your test the picture file is a PNG renamed with JPG extension: take a look please.

 

0 Kudos
RyanLibed
Esri Contributor

Hi Robert,

In the June 2022 ArcGIS Online update, the image zoom slider and download issues have been addressed. Please let me know if you still see issues. 

Thanks,
Ryan

0 Kudos
RobertoRossi
Occasional Contributor
0 Kudos
RyanLibed
Esri Contributor

@RobertoRossi,

Good observation on the image download and image zoom tool. For the image download, is there a specific file format that you were looking to let users download the image in? Or would were you looking to preserve the file format the attachment was uploaded in?

As for the image pan/zoom tool, I'll create a sample that reproduces the issue and will use that to resolve this at the next ArcGIS Online release. Thanks for reporting this!

Best regards,
Ryan

0 Kudos
RobertoRossi
Occasional Contributor

Thank you @RyanLibed 

For the image download will be great just to preserve the file format the attachments were uploaded.

The most annoying issue, at the moment, are the blurry photos...

Thank you again

0 Kudos
RyanLibed
Esri Contributor

Hi Robert,

The blurry photos issue has been addressed. Please note that Attachment Viewer will render the images in high resolution if that is how the image attachments were added. 

Thanks,
Ryan

0 Kudos
RobertoRossi
Occasional Contributor

Thank you for the good news @RyanLibed !
I tested it with Firefox, Chrome and Edge.

Now it works much better!

There is still something that may be addressed

There is still something to address:

  1. when you open the WebApp the first image of the series appears zoomed to the maximum level, just the first time you slide the photos (if you go back to the first photo the visualization is OK)
  2. for about half a second the old blur photo appears, then the good photo is loaded

Attached a GIF with the behaviour of the App

 

There is still something that may be addressed

There is still something to address:

  1. when you open the WebApp the first image of the series appears zoomed to the maximum level, just the first time you slide the photos (if you go back to the first photo the visualization is OK)
  2. for about half a second the old blur photo appears, then the normal photo is loaded
0 Kudos