HUB dataset filter text doesn't match theme color (cannot read text)

389
1
Jump to solution
04-07-2022 02:55 PM
DavidMaggio
New Contributor II

My organization has an open data HUB site with the theme colors for body background set to dark blue and the body text color set to white. When viewing the dataset details page of an item and applying an attribute filter, the text for the filter list for the selected attribute is a dark grey color. This poor contrast makes the text illegible against the dark blue background (see image). For some reason, the filter list text color doesn't follow the body text color theme. I do not see a way to change this. I could change the body background theme to a lighter color, but would prefer to change to text color to keep the look of the site as it is. Has anyone found a way around this, or is this a bug?

 

I was able to find a similar problem with the filter text in the web app builder community forum, see the link below. A solution was proposed, but I don't see a way to apply the same solution to the HUB site dataset details page.

https://community.esri.com/t5/arcgis-web-appbuilder-questions/filter-widget-cannot-read-texts-on-bla...

0 Kudos
1 Solution

Accepted Solutions
KlaraSchmitt
Esri Contributor

Hello @DavidMaggio,

I'm sorry you're experiencing this. It is definitely a bug and not something you would not be able to fix yourself. This bug has already been reported, so I'll make a note of your issue on it.

Thank you,
Klara

View solution in original post

1 Reply
KlaraSchmitt
Esri Contributor

Hello @DavidMaggio,

I'm sorry you're experiencing this. It is definitely a bug and not something you would not be able to fix yourself. This bug has already been reported, so I'll make a note of your issue on it.

Thank you,
Klara