ArcGIS Tool Problem

161
5
10-26-2020 05:39 PM
Arthur_Morgan
New Contributor III

 Hello,

I think there is a bug (please correct me if I am wrong) in ArcGIS 10.8. Every time I use the Reclassify and Extract by mask tool without changing the default output path (which is the default database that ArcGIS creates in the software installation directory), the tools work fine. But each time, when I change the output path and output filename, the tools return 9999 error. Is there a way to resolve this issue?

  

0 Kudos
5 Replies
DanPatterson
MVP Esteemed Contributor

what is the output path and filename?  If it begins with a number and the destination is a folder it will fail


... sort of retired...
Arthur_Morgan
New Contributor III

Why does it fail if a file name starts as a number? 

0 Kudos
DanPatterson
MVP Esteemed Contributor

If the output is a folder, then an esri grid will be produced. 

They cannot begin with a number, contain anything other than letters, numbers and the underscore and the length can't be > 13 characters. 

If you want to tempt fate further, try having a path with spaces and/or other non-alphanumeric characters in it.

The list goes on, but it is too late to look up one of the many references to "esri grid" issues .

If you want something other than an esri grid, then you have to output to something like a *.tif, by appending that file extension to it.  You might get away with breaking most of the above "rules"


... sort of retired...
Arthur_Morgan
New Contributor III

Does that mean I can give an output to the desired folder as ~Folder_Path/10-26-20.tif?

0 Kudos
DanPatterson
MVP Esteemed Contributor

Did you try it?

or even

10_26_20.tif in case "-" isn't accepted 

or

My_10_26_20.tif  in case tif's don't like beginning numbers

Just trying to narrow down issues?  Sometimes you have to experiment


... sort of retired...
0 Kudos