ArcGIS Hub Summary Statistic filter

1113
18
04-16-2020 04:50 AM
ZoltanKovacs
New Contributor III

Hi all,

I'm using Summary Statistics on my Hub page and would like to exclude a specific value (these values are coming from a domain list) using Filter by Attribute. There isn't much documentation on Filtering, so I was wondering if anyone has managed to set it up to exclude values? I've got like 20 different values in my domain (and it will expand further), so adding the other 19 values to the filter is not my ideal world...

I've tried the following so far:

<> Milepost

!= Milepost

NOT Milepost

NOT IN (Milepost)

These don't seem to work as I get 0 (zero) as result instead of 1582 (the correct count number without 'Milepost'). Any ideas on how to get this working would be very much appreciated.

Zoltan

0 Kudos
18 Replies
GrahamHudgins
Esri Regular Contributor

We don't yet support advanced querying. If you need a specific slice of data, best workaround I can offer is creating a feature service view that is filtered how you want....or embed a 1 widget ops dashboard (this is overkill--and watch your count of embeds on your site as it can harm performance)

This one is on the list to improve! Apologies it isn't as fully featured as it should be.

0 Kudos
ZoltanKovacs
New Contributor III

Hi Graham,

Thanks for the speedy reply. I haven't thought about FL Views, but I just gave it a go. Unfortunately the Summary Statistics seems to ignore the filter that is set and saved in the View and it still gives me the incorrect number - all counts including Mileposts...

Any thoughts?

0 Kudos
GrahamHudgins
Esri Regular Contributor

Can you send me the data item you're trying to use? If it's private do you mind sharing it to me in a group? My online username is ghudgins5

0 Kudos
ZoltanKovacs
New Contributor III

Hi Graham,

Unfortunately I cannot as this is a confidential project. However, I could share my screen to troubleshoot if that helps?

Z

0 Kudos
ZoltanKovacs
New Contributor III

Graham,

I can replicate the same with different (test) data. I've just invited you to that group so you can have a look at the FL and the View too. Let me know you thoughts, but it may be (another) Hub bug.

Z

0 Kudos
GrahamHudgins
Esri Regular Contributor

shoot you're right. that doesn't work as a solution here. I'm not able to get the issue you're having with filtering exact matches....i'll look into why the summary stat card isn't honoring view layers

0 Kudos
ZoltanKovacs
New Contributor III

That would be great, please let me know what you found. On top of that, the summary stats card doesn't allow you to add the same field with different values to the filter either, so I'm pretty much stuck here...

0 Kudos
ZoltanKovacs
New Contributor III

Hi Graham,

Did you have time to look into this yet? If not, please let me know and I'll raise it with Support. Many thanks!

Z

0 Kudos
GrahamHudgins
Esri Regular Contributor

we're still working on it! feel free to log a case - we can get them hooked up on our side once it's logged. 

0 Kudos