ArcGIS Hub - Failed to create Initiative

388
11
10-18-2019 11:50 AM
Highlighted
New Contributor II

Hello,

I have a "publisher" role in our ArcGIS organization. My colleagues are able to create a hub site, but when I try to create a site, I receive the error "Failed to create initiative". It does not give me any additional information, and when I check my groups and content, there is no new items regarding the site. Since I cannot get any detailed error message, I have no idea what is wrong, and what I should do. 

Thank you in advance!

Reply
0 Kudos
11 Replies
Highlighted
New Contributor III

Were you ever able to create initiative? There was an issue going on last week but I believe they have fixed it, here is the thread.

Reply
0 Kudos
Highlighted
New Contributor II

I've seen this thread, but it looks like they were able to create content and group but the Hub site. In my case, I cannot create anything - Hub site, content or group.  I have no idea what to do. It does not show any error code...

Reply
0 Kudos
Highlighted
Esri Regular Contributor

I recommend opening a support case. 

You could try to look in the network tab during the creation and find the response from the call that produces an error. This may offer additional insight. 

Reply
0 Kudos
Highlighted
New Contributor II

Thank you, Graham. I will probably open a support case. 

I checked the Network tab, but I did not understand what's wrong there either. 

Reply
0 Kudos
Highlighted
Occasional Contributor III

This happened to me when I was trying to create an initiative with a custom role that was missing a privilege that, at the time, was required to create an initiative (Hub Premium).  I don't know that 'minimum' privileges required to create Initiatives is posted anywhere in the Help docs...

Reply
0 Kudos
Highlighted
New Contributor II

Thank you so much for your reply, but the "Hub sites" are listed under the "Creator" tab on my user profile. According to this, I should be able to create a site.

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Creators can been limited by their admins, though. Make sure you have Create Content, Create Group, Share to Group. Those are critical to creating a Hub Site. We do have doc about this coming out imminently 

Can you please reach out to support on this issue? Supporting via GeoNet is a bit tricky. I sent them an email telling them you're coming

Highlighted
Occasional Contributor III

Hi All,

I also experienced this issue today, where it failed to create an initiative - I was using an Esri default Publisher role. When I changed to a role with additional privilege (custom pseudo-Admin role), there was no issue.

Graham Hudgins, it seems that for HUB, you need the privilege to create groups with update (not in the Publisher role). When I attempted to change the user role back to Publisher (after creating a HUB site), i got the following error message:

"Member must not own groups with update capability."

I should also mention that this user has no content, or groups, other than the content that is created when the HUB site is created. It is a brand new user account.

Jamie.

Reply
0 Kudos
Highlighted
Esri Regular Contributor

You need to remove the sites that have core teams to restore the user back to publisher. You could also delete the core teams directly if you needed to save the sites themselves

Reply
0 Kudos