Is a processor to geocode incoming address data file and output feature service in GeoEvent server 10.5?

523
3
11-21-2017 10:47 AM
XiujuZhou
New Contributor III

I just need a geoEvent processor to  geocode incoming address data file and output feature service in GeoEvent server 10.5, since I need real-time geocode data with small time interval line 5 minutes.

0 Kudos
3 Replies
JakeSkinner
Esri Esteemed Contributor

Hi Xiuju,

Currently, you cannot geocode with GeoEvent.  I recently helped a customer with a similar workflow.  Is the table a geodatabase table?  If it is, you can dynamically geocode the results:

Geocode Addresses—Help | ArcGIS for Desktop 

Set the Dynamic Output Feature Class parameter to true (checked) if you want the matching result in the output feature class to be updated automatically when the input address table is updated.

If the table is simply a database table, and not a geodatabase table, you could have a python script that appends the records to a geodatabase table at a given interval.  The dynamic geocode could be created from this geodatabase table.

XiujuZhou
New Contributor III

Thanks for the prompt response. I think it is good solution for me, even though my data is from excel file, but I can import it to database, then geocode it as table. I will try it.

0 Kudos
AdrienHafner
Occasional Contributor

Hi Jake,

I'm attempting something very similar to Xiuju in ArcMap 10.5.1/10.6.1 (I have/have tried both). For now, I'm just trying to set up the preliminary geocoding schema/workflow in my geodatabase prior to setting up in GeoEvent Server. I ran the Geocode Addresses tool on my address table with the Dynamic Output Feature Class parameter checked, which produced the expected relationship class and output feature class of geocoded results.  Now when I attempt to edit a new row into the initial address table, I'm getting the error message "Could not insert new record".  After Googling, I found this result which references VBA and mentions that the locator used is unavailable.  I thought maybe the locator needed to be in the same workspace as everything else, but I see that ability has been deprecated as of 10.5.1.  Any ideas how I can get this to work?

0 Kudos