GeoEvent Processor Register Folder issue

3206
6
09-05-2013 11:01 AM
KeithWempe
New Contributor II
I am trying to register a local folder "D:\arcgisserver\GeoEvent\Output" with GeoEvent Processor and it fails with no message. After I click register it just goes back to the main Site tab in GeoEvent Processor. I was able to successfully Register ArcGis Server but no folders.

Thanks,

Keith
0 Kudos
6 Replies
RJSunderman
Esri Regular Contributor
Have you tried registering any other system folder?  The Introduction to GeoEvent Processor tutorial chose to use C:\arcgisserver as the base folder only because that is the default server directory used by ArcGIS for Server, and we discovered that permissions for the OS-level user responsible for running the ArcGIS for Server and GeoEvent Processor services needed to be added to 'My Documents' folder when attempting to register folders such as C:\Users\<user>\Documents\ArcGIS.

Try creating a folder C:\GeoEvent on the local HDD and registering that folder. The user you've logged-in as should be the owner of that folder. If the folder fails to register with GeoEvent Processor as a Data Store, try adding the OS-level user responsible for running the 'ArcGIS GeoEvent Processor for Server' service as a local user with 'Full Control' over the folder and any sub-folders.

/RJ
0 Kudos
KeithWempe
New Contributor II
RJ,

I tried that and still did not work...

[ATTACH=CONFIG]27295[/ATTACH]
0 Kudos
WillWhite1
New Contributor
Hi,
I've just encountered this same issue. I've added a folder on C:\GeoEvent and given full control to that log-in user as well as the user running GEP but to no avail. It still doesn't register the folder and returns to the main site tab.

Did you manage to workaround this issue?

Thanks

Will
0 Kudos
JavierDelgadillo
Esri Contributor
Which browser are you using?  IE 8 is known to fail at registering Folders.  Can you try using a different browser (Chrome/Firefox)?

-Javier
0 Kudos
KyleDixon
Occasional Contributor
Anyone found a solution?
0 Kudos
AlexBellak
New Contributor III
I was having the same issue, I switched from IE 8 to Chrome and it worked.

-Alex
0 Kudos