Unable to Submit Point After Update - Worked Great Before Update

04-19-2021 09:08 AM
New Contributor III


Using the form functionality with my editable point hosted feature layer worked great last week, this week everything appears to be broken. 

I read a couple of posts, and yes, I am using the most recent version of Field Maps (21.1). 

When I fill in a form and try to submit, I get the following warnings (tried on IOS and Android) 

IOS: "Unable to submit, 1 or more attributes failed" 

Android: "Unable to submit, internet appears to be offline" 


I am definitely connected to the internet, everything worked last week, this week the app doesn't like something in the form that has not changed in a couple of weeks. 

The fields in the form contain the following: 

- Drop down menus with a number of domains 

- A calculated field using an arcade expression to add the lat/long in WGS84 to all submitted points 

- Date field 

- Open text fields 

- A hyperlink that sends attribute information to Survey123 


Please advise what happened this week that broke the app. I am supposed to release the app to our field workers this week. 


Thank you, 

0 Kudos
4 Replies
New Contributor II

Hi Emma,


Thanks for starting this thread. Our field crews have had a similar problem for a year now where periodically we will see the "unable to submit. Internet connection appears to be offline" message on Android, even though our LTE service is fine. It happens periodically, sometimes it's random and other times it will occur at around 2pm every day like clockwork. 

We are using the most updated version of Field Maps, but did not configure a smart form. We just saved the map in the map viewer. I also check the AGOL health dashboard each time and there has never been an issue there. 

I'd like to hear from an Esri rep about what could be causing this. 

0 Kudos
New Contributor II

I set up Field Maps for our Parks Department and they've experienced this issue twice now. Last time it just magically stopped. No idea what is causing it. ESRI a little help here??

Tags (3)
0 Kudos
New Contributor

We are having the same issues with both Android and Apple products (with everything updated). We are working with the provided water distribution solution ESRI offers. We did make some additions to some layers & fields, but usually only get this error when trying to collect a specific layer. Anyone find a fix to this?

0 Kudos
New Contributor II

We are having this issue for just one calculated expression. I had to concatenate the first and last name because GetUser($layer).fullName was only returning my first name. So, what I have below works when I test in Field Maps web app, and it works for me in the mobile app--I can submit, as it auto populates my name. However, it fails to calculate (and gives the unable to submit message) for two other users and works for one other besides myself. We all have the latest app version. We have tried cell data and wifi for those failed users and same results. All using iOS.

    (GetUser(Portal('https://arcgis.com')).lastName)], ' ')


0 Kudos