Samsung Galaxy S10 Error Downloading Offline Maps

06-27-2022 03:24 PM
Occasional Contributor II

Hello Everyone,

I have a volunteer that is having an issue downloading the offline maps within Field Maps that have been set up for data collection in the field. They have uninstalled and reinstalled Field Maps multiple times and they continue to get a message that says the "Download failed" when they are trying to download the offline areas. They are able to download an offline map in Survey123 just fine.

Screenshot_20220620-141539_Field Maps.jpg

Some more details on the phone include:

Samsung Galaxy S12 model SM-G973U
Android Version 10
I assume whatever the latest version of Field Maps since they are directly downloading from Google Play
Plenty of storage, the files are not large as you can see.

Is there anything that someone sees that I might be missing here or a setting that I am not asking them to check that might be changed inadvertently? It is working on others' Android based devices without issue. What has thrown me off is that they are able to download the offline map in Survey123.

Thanks for any advice.

0 Kudos
5 Replies
New Contributor III

Can confirm this is the same for me, tried on a personal device and a tablet. Might be down to the updates they are doing with ArcGIS Online but not good!

0 Kudos
Occasional Contributor

I had a similar issue with my Samsung FE S20 would not download any pre-made offline areas that were bigger than 100mb. The same areas worked fine on iPad. The weird thing is that I could generate and download quite larger user-defined offline areas from the app. It would only fail with the pre-defined offline areas that were created in the Field Map setup webapp.

0 Kudos
New Contributor

I am having the same problem. I've uninstalled and reinstalled Field Maps, and tried downloading via both wifi and cellular numerous times. My phone is a Galaxy S9, but I even tried the same things on my old S7 I occasionally use as a data collector using wifi (no SIM card) but I still get the same download failure. The basemap is 89.5 mg. It seems to be downloading fully, but then I get the same failure.

0 Kudos
Occasional Contributor II

This seems like it should be an issue that is addressed. We have about 10-15 volunteers that are unable to participate in the project as a result of this error. We are having to purchase iPads that they can checkout so they can still help out.

0 Kudos
New Contributor II

I am also having the same issue on a Samsung.

Can see all the data download and then the install on device fails.

The download works fine on iOS.

Logging shows:

Mon Aug 22 11:22:17 GMT+09:30 2022 : [DOWNLOAD] - [e017b8d831b54f368fee12a286ab66a4] - Layer: OpenStreetMap - Error: com.esri.arcgisruntime.internal.jni.CoreRequest cannot be cast to com.esri.arcgisruntime.internal.jni.CoreFileRequest :
Mon Aug 22 11:22:17 GMT+09:30 2022 : [DOWNLOAD] - [e017b8d831b54f368fee12a286ab66a4] - The map download contains one or more errors

0 Kudos