Select to view content in your preferred language

Label filter not working in Field Maps

04-16-2024 02:05 PM
New Contributor II

I've created some labels for polygons in one of my maps that make use of filters to symbolize the names of the polygons differently based on if a Notes field is blank or not. In Map Viewer, these labels work exactly as I want them to. However, in Field Maps there seems to be a bug where all of the labels are symbolized exactly the same. Panning around the map and tapping on incorrectly labelled polygons in Field Maps sometimes symbolizes some zones correctly, but this is very inconsistent and the problem usually returns. I'm working completely off of enterprise feature services. 

Below is what the map looks like in Map Viewer with the labels functioning correctly:


This is what it looks like in Field Maps with only one of the polygons symbolizing correctly:


I've tried messing with the label filters to simplify them as much as possible, but it hasn't helped. I've also tried duplicating the layer, setting the labels, and filtering the polygons themselves and that kind of worked, but the labeling engine doesn't seem to like displaying many labels at one time that way, which is a no-go for us. I got similar results when setting a single 

Has anyone else had this issue or might know some decent work arounds? 

Tags (3)
0 Kudos
0 Replies