Field Maps - Required Fields Not Working as Expected

Jump to solution
02-23-2021 07:56 PM
Occasional Contributor

Hey all,

I have been using ArcGIS Field Maps mobile and have noticed that the fields I have setup as "Allow Null" = False, don't need to be filled out when i tap "Submit".

I setup the form for the layer using ArcGIS Field Maps web app and the fields have the "Required" marked as True.


In the Field Maps mobile app, I have the asterisk next to the field indicating that the field is a required field.

In Beta, I noticed that it was released in October:


Is anybody else experiencing this?


11 Replies
New Contributor III

I finally got the chance to try this out today and it worked like a charm. Thanks for all your help, @AaronPulver . Pointing me to the ability to edit those templates in Field Maps Web was particularly good as I had still not taken the time to check out that interface and I think it will serve me well moving forward.
I did experience some of the same frustration and/or confusion that @Tolo__AdamTolo  mentioned there, namely that for non-nullable fields with a domain and without a default value I had to change each one to 'Not Selected' before I was able to save my changes to the template. This is not a big problem, but I agree with Adam that it's not the behavior I expected.

MVP Notable Contributor

I think this one is getting me today.  Maps we had for a few years now no longer forcing the required fields all of a sudden.  I am using all Map Viewer Classic. I have not touched anything in Field Maps web.  Just a straight publish from a GDB in ArcMap.

I tried the process posted to update the template but it did not make a change.

I see the space in templates.


But when I go to fix it in templates it has no space.



I have tried adding and then removing a space and a few other things but it still stays with the space in the JSON.

Nullable is set correctly

LOCAL_ID (type: esriFieldTypeString, alias: LOCAL_ID, SQL Type: sqlTypeOther, length: 255, nullable: false, editable: true)

I then tried the linked script but we have 2 factor so it fails.  Not sure why it would ask for a un/pass when it can just use the Pro login.

Unable to generate token.
Invalid username or password.
(Error Code: 400)

So now I am stuck.  Only some of my services are doing this.  Maybe a diff between publishing with Pro or ArcMap. Is this some new bug?  If so is it getting fixed?