Field Maps iPad crashes to home screen on record submit with magnetic keyboard attached

492
3
04-20-2023 08:45 AM
Galen_S_MnDOT
Occasional Contributor

Hello-

One of my Field Maps users at my agency has reported that the app crashes to his iPad's home screen frequently (if not 100% consistently) when he hits the 'submit' button on an inspection record he's completed.

He has been using this iPad + keyboard combo with Field Maps and this particular form for months now, and the problem only manifested in the last week or two.  

I couldn't verify this behavior using the same form on my own iPhone, but I was able to observe the behavior on my colleague's iPad in person.  After noticing that his input pane in Field Maps on his iPad jitters and scroll-jumps around a lot while he's trying to input information, I suggested that he remove the keyboard and try using the iPad in touch-only mode.  This seems to have solved the issue.  The UI no longer jitters and jumps around, and the form submissions are accepted without the app crashing.

I couldn't find any forum posts referring to this specific issue with iPad + magnetic keyboards.  Has anyone else experienced this or something similar?

I'm not sure which hardware version the iPad is, but it's running iOS 16.4.1.  Fields Maps is app version 23.1.0, build 984.  The magnetic keyboard is an official Apple Magic Keyboard.

Thank you!

0 Kudos
3 Replies
lah
by
New Contributor III

Thank you so much for posting, I never would have guessed the problem being with the keyboard. I also had a user report this morning his app crashing. He is using an iPad 11 pro 16.4.1 with an Apple magic keyboard, Field Maps version 23.1.0. 

The strange thing is that he was able to get one form submitted earlier this morning, but none since. I also noted that he is able to submit other data with the keyboard attached, just not this one specific feature that we have a field maps smart form tied to. 

ESRI has logged

BUG-000158013 : Data entry using a Bluetooth keyboard on iPads causes Field Maps to crash/close, after submitting

Thank you!

Galen_S_MnDOT
Occasional Contributor

I seem to remember my user reporting that he was able to successfully submit one (or a few) records before the problem became insurmountable as well.  

Since he stopped using his Magic Keyboard, he hasn't reported any issues with the specific Field Maps form in question.

Thank you for sharing that bug ID though!  Good to know they've got it logged.  

0 Kudos
RobinAlex021
New Contributor

I tried every possible fix out there untill i fixed it by checking the memory in iPhone.

0 Kudos