Field Maps Download Failures - Hosted Feature Layer related

1013
3
09-29-2023 10:48 AM
SBrandenburg
New Contributor III

Hi all,

I am the sole GIS specialist for my company, and everyone uses Field Maps through my ESRI account (we don't use it that frequently). The main way we use it is to download project areas so that everyone can collect data in the field for me to map later (wetland delineations, bio data, etc). However, I've run into some serious issues with map area download failures that I cannot seem to resolve. I worked with ESRI support for one instance, but we couldn't come to a solution and I ended up having to re-make the entire layer that seemed to be the reason for the download issues. I've noticed that if if I have copied and pasted features from one feature class into another in Pro, that pasted layer seems to be corrupt when I publish it to AGOL and results in download failures. I've been avoiding this workflow/working around it, but today I ran into download failures related to a hosted feature layer (Project Area polygon) in a map and I can't figure out what is causing it for context, here's what I've tried:

Map content: ESRI Imagery basemap, two empty online layers for data collection, hosted Project Area feature layer

  • The map will download if I remove the hosted feature layer - basemap, and two online layers work fine.
  • I re-made the feature class in Pro entirely, then overwrote the online Project Area layer and added it to the map. Download Failure.
  • I published the new Project Area feature class independently to AGOL (as opposed to overwriting the original layer) and added that to the map instead. Download Failure
  • I ended up creating a new online layer and drawing in the project area manually again, and the offline area would download

So the short version is that my offline maps will only successfully download if there are no hosted feature layers in them. I made sure to enable sync and offline maps for all of the layers and still got download errors every time I tried. 

Does anyone have insight as to why this may be happening? I am going to contact support again to report the issue, but I'm curious if anyone else has run into similar issues.

3 Replies
RhettZufelt
MVP Notable Contributor

I have seen issues similar to this when having an empty HFL in my Field Maps app.

Once I edited and added at least one 'dummy' feature (that are within the offline area) to each layer, the issue went away.

In case this is your issue,

R_

gis_KIWI4
Occasional Contributor II

@SBrandenburg - In my experience this can happen in multiple scenarios.

Have you had a chance to look at the logs in FieldMaps? You can get there by going into your profile -> Troubleshooting -> View Logs

gis_KIWI4_0-1696359060491.png

The logs might be able to show where the problem or what the problem layer might be. 

gis_KIWI4_1-1696359552390.png

 

 

In our case we were able to resolve this issue in 2 seperate scenarios.

1) Keep your field names less than 32 characters. We have learned that AGOL does not impose this limit but when you try to create an offline map it tries to create a database on the phone and it fails because the database doesn't support field length more than 32 characters. 

https://community.esri.com/t5/arcgis-field-maps-questions/cannot-download-offline-area-on-field-maps...

 

2) If you are using iOS devices then deleting the FieldMaps directory for that particular map might resolve the issue.

 

The other way of thinking about this is why did the mobile goedb creation failed? In essence, its a SQLite Database. Are there values or naming conventions that could be the problem? 

https://pro.arcgis.com/en/pro-app/latest/help/data/geodatabases/manage-mobile-gdb/mobile-geodatabase...

 

 

 

 

 

0 Kudos
SBrandenburg
New Contributor III

 I'll give this a try the next time I run into this issue. I don't think naming conventions are the problem, but the troubleshooting could tell me otherwise. Thanks!

0 Kudos