Field Maps crashes on Android after submitting an edit to an offline map

10-13-2021 09:14 AM
by Anonymous User
Not applicable

We had an offline map on a device that had been working for several weeks. We've just re-downloaded the offline area and now the app kicks you out when you submit an edit. This doesn't happen in iOS. The only thing the logs says is "Feature tiling disabled".

Problem: Submitting an edit, kicks you out of the FieldMaps app. The edit is saved on the local device because when I reopen the offline area it is there. But submitting 10 edits becomes cumbersome because you have to reopen the app after each edit.

We've tried:

1. Downloading offline area to multiple devices (androids) and can reproduce on each device with varying offline area sizes.

2. We've re-downloading the offline map areas multiple times

3. Tried downloading the map in Collector and Collector does the same thing.

4. Tried downloading on iphone and the applications don't kick you off after an edit. 

Anyone have ideas?


0 Kudos
1 Reply
by Anonymous User
Not applicable

I spent a while troubleshooting this today and discovered it was due to a layer in the map that has a relationship with a table. Once I removed the related table the offline edit was fine. We've had this related table in the map for offline editing for several years and never had an issue with offline editing.

It seems to me that Android doesn't like this structure in the offline database. Again, offline editing with this map in iOS doesn't produce the issue (crash the app after submitting an edit). We aren't even editing the layer or its related table. 

0 Kudos