Copy Features not availabe for certain feature classes in Field Maps

454
8
03-02-2021 01:43 PM
TravisSizemore
New Contributor III

Hi everyone,

Our field crew would like to use the Copy button within a feature's menu to ease their workflow. However, only certain feature classes (FCs) within the same hosted feature layer have the Copy button enabled. I have not been able to pinpoint why this is the case, or what needs to change to enable the Copy button. Does anyone know?

Things I've checked already:= between the FC that allows copy and the one that doesn't:

  • Both have relationship classes, both parent and child.
  • Both have edits enabled within the web map. 
  • Both have types with templates.
  • Both have similar symbology.

Thanks!

0 Kudos
8 Replies
DougMorgenthaler
Esri Regular Contributor

@TravisSizemore A few questions that might help me better understand the behavior you're seeing:

  • Do all layers support editing (at both the service and web map level)?
  • If editing allowed, what editing permissions are defined at the feature layer?
  • What types of geometries are the two layers you mention?   
0 Kudos
TravisSizemore
New Contributor III

Hi Doug, 

All the layers in question support editing and I can create and edit them in Field Maps, just not copy. The are a mix of points, lines, and polygons. Here's the breakdown:

"Visit" (point) - Can copy

"Territorial point" (point) - Can't copy

"Line" (line) - Can copy

"Non-territorial point" (point) - Can't copy

"Non-territorial polygon" (polygon) - Can't copy

"Incidental observation" (point) - Can copy

TravisSizemore_0-1614790674406.png

 

0 Kudos
ChrisRoot
New Contributor III

ChrisRoot_1-1619639196744.png

Try going to the Field Maps Online Map Editor.  Seems to potentially fix this issue.

1.  Open your map in the online program.

2.  Go to Settings for the map

3.  uncheck then check again the collect here and copy buttons.  

4.  Save the map (upper right hand corner floppy disk)

5.  Test in field maps app.

I found some limitations though.

1.  If you have a feature in your map that allows copying but is not editable, then when you hit the copy button in field maps, it gives you the option to copy that feature to another layer of the same geometry.  

2.  If you have a feature in your map that is editable, then the only option you have for copying is to duplicate that feature.  It does not seem possible to copy that feature to a different layer.  Unfortunately for my use, this is a drawback of the FieldMaps app.

 

0 Kudos
TravisSizemore
New Contributor III

Hi Chris,

That didn't work for me, but thanks for the suggestion anyways.

Travis

0 Kudos
ChrisRoot
New Contributor III

It didn't work for me either Travis.  That was the point of my lament at the bottom, I suppose a person could search and see if this is a suggested improvement to the FieldMaps app.  I have my reservations about that though, it seems like copying data between data layers in the FieldMaps app is prohibited for a reason.  There must be, with almost a decade of continuous trial and error usage by thousands of intelligent people, a good reason that this feature is not bread and butter of the program as you would expect it to be.

0 Kudos
TravisSizemore
New Contributor III

Chris, 

I think it would be a good option to be able to copy to another layer. I don't know what all would need to go into that, but you should go ahead and suggest it. 

I would be happy just to be able to copy editable features within the same layer. That's the part I'm still unable to do. Hopefully @DougMorgenthaler or someone else is able to find a solution. I suspect I may end up having to submit a support ticket. 

Thanks again,

Travis

0 Kudos
ChrisRoot
New Contributor III

Sometimes when you call Tech support and they really want to help out, they walk you through a whole test case and have you create a new feature from scratch, add it to a new map and test the function.  It can be painful and very time consuming, but if you can get your dummy data to copy in Field Maps, then it might help you determine that the issue is your data structure.

Im not saying that this is your situation, but I have run into issues with corrupted data structure before from using the overwrite web layer feature in ArcPro on a hosted feature layer, and what I had to do was pull my Hosted feature offline, back into ArcPro, then rehost it as a new HFL, add it to my maps.  Essentially redo everything, but sometimes its faster than finding out what the particular corrupt part of your data is.

Hope its just a check box you missed, but it looks to me like you got them all.....

GL, Root

0 Kudos
TravisSizemore
New Contributor III

Chris,

Thanks for the suggestion. In my case this feature service is fairly complex and has a lot of connections, so re-publishing is out of the question. It's also in-service currently with daily data collection. It's not vital that we can copy features, it would just be convenient and save some time for our field crews.

Thanks,

Travis

0 Kudos