Android Error - ArcGIS Runtime: Geodatabase not found

766
2
04-25-2022 08:07 AM
RonParis
Occasional Contributor

We're starting to encounter the following error on Field Maps for Android:

 

 

java.util.concurrent.ExecutionException:
com.esri.arcgisruntime.ArcGISRuntimeException: Geodatabase item not found.: The following features were not found: [180585]

 

 

This is error appears when users edit pre-existing features, and press the submit button. I can't seem to see any obvious correlation, because it doesn't happen for every feature. The error states the objectid of the feature that has generated this error. Having checked in agol, the feature is present and accounted for. Additionally to note, users are not working offline. 

Below are the hardware details:

  • Samsung Galaxy Tab S3
  • Model: SM-T825
  • Android version: 9 (Pie)
  • Field Maps version: 21.3.0 (also occurs in latest version)

TIA

0 Kudos
2 Replies
AxelLévy
New Contributor III

HI,

We have the same error. Do you have filters on your layers in the webmap? if you remove them, it should work. I notified esri support

0 Kudos
StichtseRijnlanden
New Contributor

Hi,
The same error here. The map layer where this issue occurs contains a filter. Is there an alternative for removing the filter? 

0 Kudos