Android devices error: the server you are trying to connect to is using an untrusted certificate

12-30-2021 12:06 PM
Occasional Contributor

Hello Field maps users,

We have an Enterprise 10.8.1 installation and we are using Field maps to collect street lights.

We can connect to Enterprise via URL in Chrome or any browser no error is shown  regarding certificates.

In portal and server we import root, intermediate and pfx certs and we are using pfx certificates in portal and server.  all my IOS users can connect to fieldmaps with no problem but my android users get this message

WhatsApp Image 2021-12-30 at 3.02.32 PM.jpeg


We tried to export root certificate and install it manually to android devices and no luck.


Any suggestion?

4 Replies
by Anonymous User
Not applicable


We can connect to Enterprise via URL in Chrome or any browser no error is shown regarding certificates.

Can you clarify if you can sign in with Chrome on the Android device? I'm not sure if you tested that or just with Chrome on a desktop computer.

0 Kudos
Occasional Contributor

I did a test sign in to my portal from chrome on a desktop and on my android device. 

I used and found out that my certificate chain is missing my intermediate certificate. My web server pass through a reverse proxy and I am trying to define how can I add that intermediate certificate to my  reverse proxy. I export the intermediate certificate and install it on the android device and it worked but I cannot tell my 200 users to install the certificate on their devices so now I have to check how to set that missing certificate in my implementation.





0 Kudos
New Contributor II


Any luck on this. I am facing the same issue.


Kind Regards,


0 Kudos
New Contributor II

Hey @DiegoLlamasOlivares I am facing the exact same issue too.  Did you find a way to fix this?




0 Kudos