Select to view content in your preferred language

After upgrade to 11.1 popups do not work; cannot edit/add attachments in Field Maps

410
2
09-15-2023 10:06 AM
Map2021
New Contributor III

We serve out our layers through a stand-alone server to AGOL where Field Maps consumes them. Our system was working fine. Then we upgraded our ArcGIS Server to 11.1 as well as our EGDB. Since then our popups stopped working, we can no longer edit/create features and we cannot add attachments to our editable layers. We are working with ESRI, but they seem to think we are the only ones having this issue.

Anyone else upgrade to 11.1 and have issues serving data up for Field Maps?

0 Kudos
2 Replies
PaulLohr
Regular Contributor

I have not changed to Server version 11.1 yet.

Have you tried popups in both Map Viewer and Map Viewer classic?

Did you check in your browser's Developer Tools for errors or things that don't completely load?

Did you check your ArcGIS Server logs for errors?

Can you make the popups work with the SampleWorldCities service that comes with ArcGIS Server?

Assuming you published from an APRX file, did you rebuild the APRX file from scratch and publish a new service and test with that? 

Hopefully the change to 11.1 was done in a test environment? Or maybe you imaged the production server prior to the change so you can quickly go back to the older version that was functional? It may be helpful to have a test server setup where you can load a newer version of Server and test it prior to putting it in production use.

0 Kudos
Map2021
New Contributor III

We have been able to use the popups in both versions of the Viewer. Its only in Field Maps it doesn't seem to be working. I have rebuilt the APRX and create new APRXs with the same data and after publishing have the same result. The only thing that seems to work for Popups is to stop using Map Services and switch entirely to Feature Services. However this does not solve the other issue of editing and adding feature attachments that will not work regardless of what we do. Our temp solution is to have any layer we need to edit tied to Feature Hosted Services on AGOL and then update our onprem Enterprise GDB periodically. Not very modern but it works. I've been talking to ESRI tech services and they don't have a solution.

Although ESRI tells me otherwise, I have not yet met an actual customer who has also updated to 11.1 and has is using Field Maps like we do. So I have no context to compare. Is anyone else updated yet?

0 Kudos